4

If I place a german umlaut like e.g. "ü" in the language-field of a biber entry, and if I then run biber & pdflatex the way I usually do, I get the following error:

Missing \endcsname inserted

There's no difference whether I input a plain "ü" or I use \"{u} or {\"u}. Also, changing the entry-type doesn't change things.

The interesting thing about this behaviour: placing an "ü" into one of the more common fields (like author for example) doesn't produce any error at all and works fine with many entrys for me.

I'd like to have the word "Frühneuhochdeutsch" in the language-field; any suggestions?

MWE:

The bibliography:

@Misc{Habsburg95DieHandhabungdesa,
  Title                    = {Handhabung},
  Author                   = {Maximilian I. von Habsburg},
  Language                 = {Frühneuhochdeutsch},
  Month                    = {aug},
  Year                     = {1495},

  Timestamp                = {2014-01-19}
}

The document:

\documentclass[a4paper,10pt,twoside]{article}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[babel,german=guillemets]{csquotes}
\usepackage[
backend=biber,
style=alphabetic,
natbib=true,
]{biblatex}
\addbibresource{bibliography.bib}
\usepackage{lipsum}

\begin{document}

\lipsum[1] \cite{Habsburg95DieHandhabungdesa}

\newpage

\printbibliography

\end{document}
6
  • Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. Jan 19, 2014 at 21:24
  • Do you have the file encoded to UTF8? How are you running biber on the file (what options)?
    – Werner
    Jan 20, 2014 at 7:06
  • 2
    it must e one of the supported languages. See table 4 in the biblatex documentation.
    – user2478
    Jan 20, 2014 at 7:30
  • @Werner well, places other than the regular document (see MWE) where options can be made?
    – user43961
    Jan 20, 2014 at 9:13
  • 1
    biber is only for sorting. The main package is biblatex you have to use a custom field if you want to use it for your own language setting.
    – user2478
    Jan 20, 2014 at 9:15

1 Answer 1

2

use language=auto or one of the predefined languages in table 4 of the biblatex documentation.

4
  • sorry, I'm a bit confused: doesn't this option deal with the language of the bibliography? Cause what I wanted to do was just adding to one of the bib-entries the information that the source - which this entry refers to - is written in "Frühneuhochdeutsch"...
    – user43961
    Jan 20, 2014 at 13:18
  • then use a custom or note field for it.
    – user2478
    Jan 20, 2014 at 13:41
  • but wouldn't that mean I had to fully recreate a proper biber style for that in order to get this information printed?
    – user43961
    Jan 20, 2014 at 13:44
  • use a style which uses the note field.
    – user2478
    Jan 20, 2014 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.