This question already has an answer here:

When I tried usepackage{stix} I got an error .sty not found. Assumed stix was not installed with TeX Live when I downloaded it last year. I use TeX Live 2012 on Windows (Vista) with pdfLaTeX.

So now my first try at installing a font. I got the zip from CTAN and put the resulting "stix" folder in my C:\program files\texlive\texmf-local\ directory. Then basic installation: texhash, updmap, texhash. Still same error, no stix.sty.

I think my install failed. Either the "stix" folder is in the wrong place/format (but I'm the only user+admin on this pc) or updmap --enable Map=stix.map went wrong. Any ideas on how to solve this problem? I would like to at least be able to install a font from CTAN but not spend hours reading expert font/texlive documentation ...

marked as duplicate by Speravir, Peter Jansson, henrique, Martin Schröder, Benedikt Bauer Feb 19 '14 at 21:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Is updating to TeX Live 2013 an option? I ask because you could then get this using the include package manager (if it isn't in the download - it is part of the current installation I have but maybe from an update). Where did you put stix.sty relative to the texmf tree you installed into? It should be at tex/latex/stix/stix.sty. – cfr Jan 20 '14 at 2:52
  • If you are referring to tlmgr I believe that is present already. Also I am not sure how to update and what the risks are. Regarding stix.sty, there was no .sty file in the CTAN download. – Jayvl Jan 20 '14 at 13:44
  • tlmgr in TeX Live 2012 will not update to 2013 - you have to download a new version for that. The new tlmgr will then allow you to update TeX Live 2013. On Linux or OS X the risks of installing TL 2013 are essentially nil since you can arrange things so that you also keep TL 2012 available. (I currently have TL 2013, 2012 and 2011 installed.) You just make one TL 2012 active and disable 2013 if 2013 has issues. I know nothing about Windows, though, so I don't know if you can do the same there. – cfr Jan 20 '14 at 15:48
  • If there was no stix.sty in the download, then it is not surprising that LaTeX cannot find it when you try to load it with \usepackage{stix}! The package should include this. Maybe the LaTeX support is in a different package? – cfr Jan 20 '14 at 15:50
  • 1
    I assumed can not find stix.sty was a generic error after using \usepackage{stix}. And once it realizes stix is a font it will not search for a .sty file. I now see a dtx file, after running latex stix.dtx I now have a .sty (also .aux and .log were created). Will retry installation steps. – Jayvl Jan 20 '14 at 16:47

I think I've fixed it. Thanks cfr for the input btw. I had to move the subfolders (7, excluding doc/) to the proper locations under texmf-local/fonts and indeed texmf-local/tex/latex. Before that I also had to run latex on the .dtx and .fdd file separately. After typing R in the cmd prompt it finished leaving me with a bunch of .fd files and a .sty file.

I dumped all the files in their respective folder (e.g. all .vf in vf/, without a subfolder for stix) so it is messy. I will test with subfolders later, according to the structure described here: Manual font installation.

I guess unzipping stix.zip should have moved everything to their correct subfolder automatically, this was not the case (using winrar). I was also worried because updmap-sys did not seem to change anything. Also wondering if my TEXMFVAR and TEXMFCONFIG locations were interfering, but I left these alone. Oh and for those interested: TEXMFHOME = TEXFLOCAL here since I am only user.

Not the answer you're looking for? Browse other questions tagged or ask your own question.