5

I installed texlive2013. Old functioning LaTeX files complain now for missing files:

No file LGRcmr.fd.! LaTeX Error: This NFSS system isn't set up properly.

Asking pdflatex it answers:

For encoding scheme LGR the defaults cmr/m/n do not form a valid font shape

Googling, I found the suggestion to load additional packages: greek-fontenc, greek-inputenc, cbfonts-fd, cbfonts The third one, cbfonts-fd, is nowhere to be found in OpenSuSE:s texlive distribution. The other packages are not enough: Same error shows up after installing them. Where can I found cbfonts-fd ?

  • The missing files are in the package babel-greek – user44603 Jan 23 '14 at 3:28
  • According to a comment to Herbert you have a special OpenSuSE version. Maybe there is something buggy. In German usenet group de.comp.text.tex another user complained about this, too. If you understand German, see this answer (but the most important are the web links): groups.google.com/d/msg/de.comp.text.tex/qVFZ6sN8ZJw/… In short: first deinstall, then install dummy-package from CTAN, then full vanilla TeX Live. There two alternatives linked, one of them in German. – Speravir Jan 23 '14 at 4:14
3

install with SUSEs package manager

| texlive-lgreek     | LaTeX macros for using Greek fonts
| texlive-lgreek-doc | Documentation for texlive-lgreek       
| texlive-lgrx       | Greek text with the LGR font encoding       
| texlive-lgrx-doc   | Documentation for texlive-lgrx
  • Unfortunately, it doesn't help. After loading, the error persists. LGRcmr.fd is not among those packages. It can be found in cbfonts.fd, but that package does not seem to be available in the OpenSuSE distribution. What am I doing wrong? – MNatiello Jan 20 '14 at 14:40
  • run updmap --all or for MiKTeX update the font setting – user2478 Jan 20 '14 at 14:45
  • I've done that, but the error is still there. As root, I run mktexlsr; updmap-sys; mktexlsr. Note that there is no option --all. There is a --force, in case you meant that. updmap-sys complains about kanji fonts, but that doesn't matter. On the other hand, running updmap as user gives an error line: updmap: Directory "/var/lib/texmf/fonts/map/dvips/updmap" isn't writable: at /usr/bin/updmap line 1302. – MNatiello Jan 20 '14 at 15:14
  • then it looks like a corrupt NFFS installation. In stall it new. – user2478 Jan 20 '14 at 15:23
  • 1
    Thank you. However, I think that the real problem is that there is no package cbfonts-fd in the OpenSuSE distribution. There exists texlive-cbfonts, but not the accompanying cbfonts-fd, which is the one that provides the missing file. At least, I couldn't find cbfonts-fd in the official repository. Am I looking in the wrong place? – MNatiello Jan 20 '14 at 19:26
2

In 12.3 there is a feature of Zypper for this:

use zypper install 'tex(<<package filename.extension>>)

So for you this will be (Withoutput)

bash:>zypper install 'tex(lgreek.sty)'

Loading repository data...
Reading installed packages...
'tex(lgreek.sty)' not found in package names. Trying capabilities.
Resolving package dependencies...

The following NEW packages are going to be installed:
  texlive-lgreek texlive-lgreek-doc 

The following recommended package was automatically selected:
  texlive-lgreek-doc 

2 new packages to install.
Overall download size: 215.0 KiB. After the operation, additional 226.9 KiB will be used.

Source, (I was stuck and worked this out just now)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.