2

I'm not able to indent the paragraphs in my apa6 class document. For my masterthesis the supervisor wants all the paragraphs indented but the first one after the title. So far, I've tried the following commands but It hasn't worked out yet:

\setlength{\parindent}{15pt}
\indent

My minimal working example:

\documentclass[12pt, onecolumn]{apa6}
\usepackage[utf8]{inputenc}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style= apa, backend=biber]{biblatex}
\bibliography{/Applications/TeX/library}
\DeclareLanguageMapping{american}{american-apa}

\begin{document}
\setlength{\parindent}{1.27cm}
\section{Section1}
Paragraph one (not indented)

Paragraph two (should be indented but isnt)

\end{document}

I'm glad for any advices on this :) Cheers!

2
  • If you try your example with some more text, I think you will see that both paragraphs are indented. What you want to do is to suppress the indentation before the first paragraph. Leave a blank line after the \section command, and then start the first paragraph with \noindent.
    – Thruston
    Jan 20 '14 at 14:24
  • Do you really want to have your entire document to be APA-style or just the bibliography? In the latter case you could use an APA-style bib setting with any LaTeX class.
    – masu
    Jan 20 '14 at 14:38
2

The problem with the apa6 class is the exact opposite to what you mention: by default, the first line of all paragraphs, including the first line of the first paragraph after a sectional unit, are indented.

To suppress the indentation for the first line after a sectional unit of type \section and \subsection, you can redefine the values of some skips defined by the class (in my example, I suppreseed some packages that were not relevant to the issue discussed):

\documentclass[12pt,onecolumn]{apa6}
\usepackage[utf8]{inputenc}
\usepackage[american]{babel}

\makeatletter
\b@level@one@skip=-2.5ex plus -1ex minus -.2ex
\b@level@two@skip=-2.5ex plus -1ex minus -.2ex
\makeatother

\setlength\parindent{1.27cm}

\newcommand\Text{Some test text for the example }

\begin{document}

\section{Test section}
\Text\Text\Text\Text\Text

\Text\Text\Text\Text\Text

\subsection{Test subsection}
\Text\Text\Text\Text\Text

\Text\Text\Text\Text\Text

\end{document}

enter image description here

I would suggest you to use, if possible (i.e., if your supervisor allows you), a different document class; personally, I don't like the settings offered by apa6.

3
  • Great. It worked! Thanks a lot. However, now I have the problem, that when I want to flushleft the text (style rule for the thesis) the indentation disappears. I cant have both, right? Which other class would you suggest using?
    – teeglaze
    Jan 20 '14 at 15:39
  • 1
    @teeglaze Since \raggedright sets \parindent to 0pt, you need to set \parindent after \raggedright, using something like \raggedright \setlength\parindent{1.27cm} in the preamble. Perhaps you could load the ragged2e package and use its \RaggedRight command instead of the standard \raggedright. As to which other class to use, it depends mainly on the specific requirements you need for your document. A number of questions in this site refer to writing thesis, so you could search and take a look; if no answer satisfies you, you can always start a new question. Jan 20 '14 at 16:10
  • Ok, Thanks! I am really glad that you - with your expertise - helped me out ;)
    – teeglaze
    Jan 20 '14 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.