41

I am attempting to install language tool on my texstudio distribution in order to check my grammar. Currently, I am following this guide to install Language tool. http://wiki.languagetool.org/checking-la-tex-with-languagetool

The problem is, I cannot find languagetool-standalone.jar nor LanguageToolGUI.jar in any of the downloads at the bottom of http://languagetool.org/ . Can anyone tell me where can I locate these files?

5
  • Isn't it just the standalone desktop tool?
    – daleif
    Jan 23, 2014 at 16:48
  • Supposedly. I extracted all 3 downloads and am still unable to find the files.
    – Wet Feet
    Jan 23, 2014 at 17:32
  • If it helps, I running Windows 7.
    – Wet Feet
    Jan 23, 2014 at 17:33
  • I have also left instructions for integrating LanguageTool into TexStudio here
    – Foad
    Oct 31, 2019 at 8:14
  • I get an error just as Foad did, with error msg = LT current status: error. Then I changed the URL to localhost\8081/v2/check. Then LT current status: working is shown.
    – AutoTrader
    Dec 13, 2021 at 5:26

4 Answers 4

14
+100

I am using TeXstudio with Language Tool under Windows 7 without any problems. The entry in the wiki is not valid for the newest version. You need to use the languagetool.jar. Then everything should work. All the other files you mentionend, existed in previous version of the tool, but are now removed. See the changelog.

8
  • 1
    Which file do I download? Also, do you know which are the exact names of the files? Because I cannot find anything about filenames being changed in the changelog (it must be too far back that it has been removed)
    – Wet Feet
    Jan 24, 2014 at 15:48
  • 1
    @WetFeet Just download the newest version as a zip, which is 2.4.1, and then everything should be fine. Unpack the zip-file in the directory you like and start the languagetool.jar. The change of the file names occurred in the recent version 2.4
    – kristjan
    Jan 24, 2014 at 23:24
  • How do I start the languagetool.jar? When I double click it my computer opens it like a compressed folder.
    – Wet Feet
    Jan 26, 2014 at 13:07
  • how do I start languagetool.jar? When I double click it, my computer opens it like a compressed folder.
    – Wet Feet
    Jan 26, 2014 at 13:07
  • You need to install the java jre first to execute jar files.
    – Simon H
    Jan 26, 2014 at 21:38
28

You may follow the steps as shown in the clip (https://www.youtube.com/watch?v=VYIY7bbSv4Q):

  1. Download and install Java of 32 or 64 bits version from http://www.java.com/en/
  2. Download Language tool from https://dev.languagetool.org/http-server (Old versions: https://languagetool.org/)
  3. Unzip the downloaded package and open languagetool.jar. Open "Text Checking"-> "Options", tick "Run as server on port" and set it as 8081. enter image description here
  4. Open Texstudio and click on "Options"->"Configure Texstudio". Check the "Inline Checking" in "Editor" section. Make sure that "Show advanced options" in the lower left corner is checked, and modify the "LanguageTool" in "Grammar" section as below. Specifically, set "Server URL" as "http://localhost:8081", "LT Path" and "Java" respectively as the paths of "languagetool-server.jar" (Old Version "languagetool.jar") and "java.exe". enter image description here

To test this, (re)start texstudio, and check whether the Languagetool is running on the desired port by navigating to http://localhost:8081/ on your machine.

Note that the TexStudio 2.12.6 does not work with Languagetools version > 3.5 since the http API is no longer offered. (Fixed in a later version)[https://sourceforge.net/p/texstudio/bugs/1842/].

9
  • 2
    It's far better to include the relevant parts of what you reference...
    – Werner
    Dec 11, 2015 at 5:17
  • Hi @Werner the clip is just as short as 3m; and an elaboration seems to be redundant and irreverent of the originality.
    – Roger Yau
    Dec 12, 2015 at 12:09
  • Answers here should be self-contained so there's minimal click-through to other sites for information. What would happen to the value of your answer if the YouTube video is taken down? Your answer would become completely irrelevant.
    – Werner
    Dec 12, 2015 at 18:15
  • 2
    @Werner Sorry for my ignorance and thanks for your reminding. Details completed.
    – Roger Yau
    Dec 31, 2015 at 9:19
  • 2
    To update. In TeXstudio config, "Language check", "Server URL" must have: "localhost:8081/v2/check".
    – djnavas
    Nov 14, 2017 at 9:50
17

The answer for Linux Users ;)

  1. Download the LanguageTool for desktop
  2. Unpack the downloaded .zip file (just provisionally) in your download folder. The terminal command is, for example, unzip LanguageTool-stable.zip
  3. In the unpacked folder you will find the version subfolder LanguageTool-5.5 (of course the exact name depends on the LanguageTool version)
  4. Move the version subfolder to an appropriate directory. I personally recommend the directory /opt. Therefore, write in terminal sudo mv LanguageTool-5.5 /opt
  5. Adapt the Settings in Texstudio (Options > Configure TeXstudio > Language Checking > LanguageTool) There you introduce following: (see picture)

a. The path of the languagetool-server.jar file in the LT Path field. In our case we type: /opt/LanguageTool-5.5/languagetool-server.jar

b. The path to the java platform in the Java field. In our case we type: /usr/bin/java (of course it is prerequisite that you hava java installed)

enter image description here

Thanks to @shivang-patel for providing the updated link to the application. And to @soham for giving the new name of the .jar file.

In old versions of LanguageTool (e.g., version 4.7) the name of the file is languagetool.jar

8
  • 3
    When I did your approach localhost:8081 returns: Error: Missing arguments for LanguageTool API. Please see https://languagetool.org/http-api/swagger-ui/#/default@loved.by.Jesus
    – alper
    May 4, 2018 at 9:08
  • Sorry @Alper, I have no idea what the error's cause is. I hope you have found the answer (maybe in another forum). If you find the answer, please write it down here as a comment or, better, link it. If it is relevant we can add it to my answer. ;) May 6, 2018 at 18:27
  • How do we use it after that configuration?
    – skan
    Jan 7, 2019 at 23:38
  • 3
    Please check this link: dev.languagetool.org/http-server.html All info available related to Language Tool. Jun 24, 2021 at 14:23
  • 1
    You just need to give languagetool-server.jar in the LT path, instead of languagetool.jar. Save your 15 mins.
    – soham
    Oct 26, 2021 at 15:22
14

This is a recent and more detailed solution for Windows users.

  1. Make sure the last version of TeXstudio is downloaded from its website.
  2. Download the English dictionary (*.oxt) from here to the directory C:\Program Files (x86)\TeXstudio\dictionaries.
  3. Download languagetools (*.zip) from its website (I used D:\Applications\LanguageTool-4.8 as its directory).
  4. Navigate to LanguageTool directory, then open languagetool.jar. Go to Text Checking > Options, then check Run as server op port and type the port number 8081. Click OK and close.

enter image description here

  1. Open TeXstudio and go to Options > Configure TeXstudio > Language Checking while making sure the Show Advanced Options is checked.
  2. Click on Import Dictionary... and navigate to C:\Program Files (x86)\TeXstudio\dictionaries, then choose the dictionary *.oxt you downloaded.
  3. Make sure the default languae is selected (e.g. en_US), and the thesaurus is selected from the same directory (e.g. th_en_US_v2.dat).

enter image description here

  1. Check Start LanguageTool if not running.
  2. Set the values Server URL, Java, LT Path and LT Arguments to http://localhost:8081/, java (as recommended here), <directory of LanguageTool*-*>\languagetool.jar and org.languagetool.server.HTTPServer -p 8081 --languagemodel --allow-origin "*" (as recommended here), respectively.

enter image description here

In order to make sure everything is fine, click on Help > Check LanguageTool in TeXstudio. The output should be something like this

enter image description here

1
  • 2
    I have problems with LT on macOS as described here. when running the Check LanguageTool it returns Tries to start automatically. LT current status: error
    – Foad
    Apr 15, 2020 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.