4

Here is data about my problem that I consider relevant:

a) I'm using lualatex

b) Here is my prelude:

\documentclass[b5paper,twoside]{memoir} 
\usepackage{graphicx}
\usepackage{polyglossia}
\usepackage{fontspec}

\setmainfont{Fanwood}
\setdefaultlanguage{english}

\begin{document}
...

c) And here is the latex input of one of the problematic fragments:

A not very precise answer to 
this question would be 
``a system for which the
predictive  power of current human rationality is limited''

Now, the problem is that there are no openning quotation marks in the output, I get something like this:

``a system for ... " 

(there is a closing quotation mark with the correct glyph). The problem is somehow related to the font Fanwood; if I comment it everything works. But Fanwood has a glyph for open quotation marks at Unicode U+201C, I checked in "Character Map", a font and unicode inspector of Linux. So I suspect that there is something more...

Question: how do I get around this problem?

This of course could be the duplicate of some question, if so, please point it to me please! So far no luck.

5

This is not a flaw in Fanwood. To use ASCII notation for quotation marks and dashes with fontspec, add the feature [Ligatures=TeX]: \setmainfont[Ligatures=TeX]{Fanwood}. See section 10.1 of the fontspec manual.

  • Thanks! It works this way. I read into the fontspec manual and I found that ligatures for opentype are controlled by a separate option. – dsign Jan 22 '14 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.