8

I'm using dot2texi to embed mindmaps (= graphs) with arbitrary latex markup in nodes and on edge labels in latex documents (compiled with pdflatex) which should be layout completely automatic. Atfter experiencing great results with nodes. I'm wondering why my edge labels are not displayed when they are in the texlbl attribute. Please take a look at the following example:

\documentclass[a4paper,10pt]{article}
\usepackage[utf8]{inputenc}

\usepackage{dot2texi}
\usepackage{tikz}
\usetikzlibrary{shapes,arrows}
\usepackage[german, ngerman]{babel}
\usepackage[babel, german=quotes]{csquotes}

\begin{document}
\begin{dot2tex}[tikz,autosize, scale=1.0, dot]
  digraph G {
    A [texlbl="\begin{minipage}{5cm}ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP ABCDEFGHIJKLMNOP \end{minipage}"];
    B [texlbl="B"];
    C;
    A -> B [texlbl="\begin{minipage}{10cm}abcdefghijklmnopqrstuvw abcdefghijklmnopqrstuvw abcdefghijklmnopqrstuvw abcdefghijklmnopqrstuvw abcdefghijklmnopqrstuvw \end{minipage}"];
    C -> B [texlbl="\begin{minipage}{10cm}1234567890 1234567890 1234567890 1234567890 1234567890 1234567890 1234567890 1234567890 1234567890 1234567890 1234567890 \end{minipage}"];
    B -> C;
  }
\end{dot2tex}
\end{document}

Adding the tikzedgelabels option causes horrible layout.

When I add label=" " to the edges, the layout happens with dot layout but is errornous with circo, neato, twopi and fdp.

What am I missing?

EDIT: this is a pending issue which will be part of dot2tex 2.9 (see https://code.google.com/p/dot2tex/issues/detail?id=18 for details)

5
  • I didn't have such a problem (but I haven't use Graphiviz for a while) with label=, see here. That said, perhaps it is due to the fact you're adding a minipage environment. Jan 22, 2014 at 14:29
  • That's interesting! Same result with parbox instead of minipage. Writing in label displays the content without recognition of latex markup. Jan 22, 2014 at 16:37
  • 1
    Perhaps your "edit" constitutes an answer?
    – Adam Liter
    Jan 29, 2014 at 3:49
  • I'm voting to close this question as off-topic because as noted in the edit this is due to a bug in the software.
    – Joseph Wright
    Dec 17, 2015 at 10:24
  • @JosephWright Can we re-open this quickly so that I can post my edit as an answer? One more question solved on the on hand, it remains off-topic on the other. Jul 5, 2018 at 21:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.