I'm using TeXmaker on a Mac. I created my .tex file. I compiled it and the editor tells me that the .log file is created and the PDF file is written. Then, when I click on view PDF, it gives me the error message file not found.

How can I fix this problem? The problem wasn't occurring in Ubuntu, same .tex file and settings.

Any help would be appreciated.

3 Answers 3


check the filename and directory, maybe Texmaker struggles to work with some characters in the filepath. Try out the internal viewer and some external viewer. -> Preferences

& Check if the .pdf has been written and try to open that file with the Mac pdf viewer

You should also set pdflatex to run when compiling, not pdftex.

  • file name and directory are fine and there are no special characters. Working with the external viewer doesn't change anything and the strange thing is that at the end of the log file it says that the PDF has been written, but then that file doesn't exist either in the folder or in rest of the laptop. Plus I don't understand why all of this was warking perfectly on ubuntu and suddenly doesn't on a Mac
    – Valentina
    Jan 24, 2014 at 13:15
  • Now that I think of it, I already had in the folder the .log file created my texmaker in Ubuntu. I removed it now from the mac and the problem now is that it can't create a new log file. And the same problem occur with a test I ran. It says that it can't start the command quick build. In the settings I selected PDFLaTeX to compile. Any suggestion in this case?
    – Valentina
    Jan 24, 2014 at 13:52

I had the same problem, using a portable version of MiKTeX and TeXmaker on USB. It worked fine on my laptop (Windows 8.1) but then it stopped compiling and generating new PDFs on my work PC (Windows 7). When I deleted the old PDF file, it told me File not found, even though I had tried to compile a new one. For me, the simple solution was to got to Options --> Configure TexMaker and re-select the correct file path to pdflatex.exe in the second field (called "PdfLaTeX"). For some reason, this file path (for me this was E:/MikTex/miktex/bin/pdflatex.exe) had disappeared, even though my USB Stick is defined as drive E:/ on both computers. It's an easy thing to miss and it took me forever to figure out that THAT was the simple problem, so I hope it may help other people who encounter the same error.


I had the same problem and after trying for two days i found out I had a problem in a figure. The figure was a .PNG, it was in the correct directory, but I have previously changed the file format by renaming it. I reopened the figure in a image editor and saved it again so it reconfigured colour properties etc. An then when i compiled the .tex file it worked properly. PS. I kept the file format and the original directory.

  • This one did it for me as well. Look at your tex carefully.
    – MDMoore313
    Feb 25, 2015 at 2:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .