12

Is there a possibility to change biblatex's maxnames option in the middle of the document?

Background: I am including a list of my own publication at the end of my thesis. I include also some papers where I am not the first author, so I need to show the full list of authors here.

The most helpful comments I found are in this question.

As far as I understand:

  1. Using the options field in the .bib file won't work without some additional work and duplication of entries in the bib file, since I might cite the same article in the main document (where I want to have only maxnames displayed at maximum) and in my publications list (where I need full author list.

  2. Duplicating my own articles into a second file would be possible. I'd still prefer a pure biblatex solution without the need to adapt the .bib file. If that is the only way, though, I'd need advice on how to get this to work as well.

Many thanks in advance!

Regards, Andreas

Here is the MWE:

\documentclass{article}
\usepackage{biblatex}
\usepackage{currvita}

% just for demonstration
\ExecuteBibliographyOptions{maxnames=3}
\addbibresource{biblatex-examples.bib}

\begin{document}
\section{Main Document}
Here I write about our method \parencite{herrmann}.

\printbibliography

\clearpage
\begin{cv}{Max Mustermann}

  %% personal information
  \begin{cvlist}{Personal Information}
    \item[Date of Birth] 01 March 2013
    \item[Place of Birth] Berlin
    \item[Nationality] German
  \end{cvlist}

  %% Publications
  %% \ExecuteBibliographyOptions{maxnames=99}
  \setlength{\cvlabelwidth}{0mm}
  \begin{cvlist}{Publications}
    \item \fullcite{herrmann}
  \end{cvlist}

\end{cv}

\end{document}
14

If you are going to populate your "List of Publications" through \fullcite commands, you can issue the command

\AtNextCitekey{\defcounter{maxnames}{99}}

just before each \fullcite in the "List of Publications".

MWE:

\documentclass{article}
\usepackage{biblatex}
\usepackage{currvita}

% just for demonstration
%\ExecuteBibliographyOptions{maxnames=3}
\addbibresource{biblatex-examples.bib}

\begin{document}
\section{Main Document}
Here I write about our method \parencite{herrmann}.

\printbibliography

\clearpage
\begin{cv}{Max Mustermann}

  %% personal information
  \begin{cvlist}{Personal Information}
    \item[Date of Birth] 01 March 2013
    \item[Place of Birth] Berlin
    \item[Nationality] German
  \end{cvlist}

  %% Publications
  %% \ExecuteBibliographyOptions{maxnames=99}
  \setlength{\cvlabelwidth}{0mm}
  \begin{cvlist}{Publications}
    \AtNextCitekey{\defcounter{maxnames}{99}}
    \item \fullcite{herrmann}
  \end{cvlist}

\end{cv}

\end{document} 

Output:

enter image description here

Otherwise, if you are not using commands like \fullcite before your "List of Publications", load biblatex with the options maxcitenames=99,maxbibnames=3:

\usepackage[maxcitenames=99,maxbibnames=3]{biblatex}

If you, instead, are going to print a second bibliography, issue the command

\AtNextBibliography{\defcounter{maxnames}{99}}

just before it and you will have the first bibliography with maxnames=3 and the second with maxnames=99.

  • Thank you very much. Indeed, it works nicely with my MWE. Not with the real thesis, though. I'll have to look for interfering packages/options. Do you have an educated guess, what might be the culprit? – Andreas Jan 25 '14 at 9:01
  • @Andreas Unfortunately, I have not a crystal ball :-) Do you have any custom code involving biblatex? – karlkoeller Jan 25 '14 at 9:04
  • Not that I am aware of. I use some package options (natbib, ...) but they work fine in the MWE as well. Other than that I do not see anything obvious (search for 'bib' and 'cite' returned nothing). I was just hoping you had that crystal ball to save some of my time checking... – Andreas Jan 25 '14 at 9:33
  • Turned out I am just not able to read properly. I had not realized that \AtNextCitekey only affects one citation. It works now. Thanks again. – Andreas Jan 25 '14 at 12:35
  • 1
    @Andreas It was written not too well in my answer. See the edit. – karlkoeller Jan 25 '14 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.