1

I recently moved from Texmaker to TeXstudio, and there is one thing in autocompletion that I loved with Texmaker and which doesn't seem to work by default on TeXstudio : when I would begin to type \frac in Texmaker, it would autocomplete with {}{} and once I filled the first {}, pressing tab automatically moved to the second {}. This does not work by default on TeXstudio. Is there a a way to make it do that?

1
  • Use ctrl+ right arrow
    – azetina
    Jan 27, 2014 at 15:36

1 Answer 1

2

Using CTRL + Right will suffice under TeXstudio 2.6.6 (hg 4105+:b24377c712d7+) using Qt Version 4.8.5, compiled with Qt 4.8.5 R.

The manual says under section 1.5 Configuring the autocompletion:

Use Placeholders: if the completed commands have options which need to be filled out, "place holder" are put at this positions and they can be jumped to by using Ctrl+Right/Ctrl+Left.

enter image description here

7
  • What is your TeXstudio version? My shortcuts to that are different.
    – Sigur
    Jan 27, 2014 at 15:44
  • @Sigur TeXstudio 2.6.6 (hg 4105+:b24377c712d7+), Using Qt Version 4.8.5, compiled with Qt 4.8.5 R
    – azetina
    Jan 27, 2014 at 15:45
  • @Hal You are welcome. Happy TeXing!
    – azetina
    Jan 27, 2014 at 15:48
  • @azetina, if you agree, please, accept my edit.
    – Sigur
    Jan 27, 2014 at 15:48
  • I don't like those shortcuts, since I use them to move one word left/right. Usually I use alt instead.
    – Sigur
    Jan 27, 2014 at 15:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .