2

I am trying to get the glossaries package to work. I have created a minimal .tex file to test it.

I am using TeXworks. My .tex file currently looks like this:

\documentclass{amsart}
\usepackage{amsmath, amssymb,amscd}

\usepackage{glossaries}

\newglossaryentry{test}{
    name=Test,
    description={is a test}
}

\makeglossaries

\begin{document}

This is a \gls{test}.

\printglossaries

\end{document}

The compiled pdf has the sentence "This is a Test", but there is no glossary list. I am currently compiling under the option "pdfLaTeX+MakeIndex+BibTeX".

I have tried compiling just under MakeIndex by itself and then compiling the pdf again, but there is still no list.

I have tried adding a "makeglossaries" option to the list of compiling options according to the following directions I found:

"You go to TeXWorks > Preferences > Typesetting, and add a processing tool. Name it "makeglossaries" (or whatever you'd like, really), enter the program "makeglossaries" (which should be already installed somewhere---don't worry about the full pathname), and add a single argument: "$basename" so that your main filename will be passed to the makeglossaries process."

But when I compile under the new "makeglossaries" option I get the following error:

makeglossaries.exe: The Perl interpreter could not be found.

After searching for info on this error I downloaded ActivePerl, following the link from this Stack Exchange question: Perl Interpreter could not be found. But I still get the error when compiling under the "makeglossaries" option.

Can anyone help me figure out how to get the glossary list to appear in the compiled pdf?

  • 1
    Is perl.exe on your operating system's path? To test it, open the command prompt and run perl --version. – Nicola Talbot Jan 28 '14 at 21:23
  • After doing what you said I get message beginning: This is perl 5, version 16, subversion...., along with some copyright information. – Gabe Conant Jan 28 '14 at 21:28
  • Okay, it sounds like perl has been correctly installed, so I'm not sure what the problem is. I don't use Windows, so I can't help further, but perhaps someone else can. – Nicola Talbot Jan 28 '14 at 21:32
  • Good know the install worked. Thanks for trying! – Gabe Conant Jan 28 '14 at 21:33
  • Do you use MiKTeX or TeX Live? – Speravir Jan 28 '14 at 22:07