4

So I use LaTeX a lot for work. I'm in the process of creating a new academic CV.

I found a beautiful template that I really love, but handles bibtex references in an unweildy manner. It assumes something is a conference piece or a journal article by the type of bibtex entry. (@misc, @inproceedings, @article, etc)

This is problematic since for example, I have workshops I've attended that published proceedings and were counted as "peer reviewed". Sometimes they were not peer reviewed, but these would be lumped together with the first CV's approach. Another issue is the whole @misc section is a jumble of posters, invited talks, and links to news articles about me.

My old cv template isn't very pretty, but it handles bibtex citations in a much more usable manner.

Basically, it lets you predeclare your categories and list the cites that go in each. (Example below)

\bibliography{pubs}
\addtocategory{books}{MWH3,ITSM91,ITSM94,expsmooth08}
\addtocategory{papers}{BHG91,BH92,YW93,Hyndman94,HDRF95}
\addtocategory{papers}{HDR96,HBG96,HF96,GHH97,HW97,LFSH97,GH98}

Ideally, I'd like to use the citation method from my old CV, but with the visual look from the new one.

I've attempted merging the new resumé's .cls and the old resumé's .sty, but I know very little about making templates and just get a mass of errors. It seemed like a simple matter of replacing one template's references code with the other, but I can't get it to compile.

Is there any way I can force the new CV style I found to let me have my own custom groupings?

I tried pulling the citation code from one templatr and puttin it in the other, but it just leads to a mass of errors, and no matter how much I google I can't get it to compile. Any help would be greatly appreciated.

  • 2
    Welcome Greggarious. It would help if you provided a minimal working example illustrating what it is that's not working as expected. Also, are you aware that the template you'd like to use is based on biblatex? You might want to check out the documentation of this package, it handles a few things differently to bibtex, but ultimately is much more powerful. – Christoph B. Jan 31 '14 at 10:27
  • Thanks, It's kind of hard to do a traditional minimum working example since I can't get it to compile... I've got the source code I used for the .sty here. And here is a link to a stripped down example CV. I googled for documentation, and it looks like my .bib file should work with both... – Greggarious Feb 2 '14 at 1:08
  • Oh, sorry, I just realized now that your old cv also uses biblatex, my bad. I'll see if I can do anything to help in the next couple of days, but this could well be out of my reach. – Christoph B. Feb 2 '14 at 13:05
3

This uses a modified version of friggeri-cv.cls. Open the file, go to the Bibliography part and add the option backend=biber to the biblatex package option. Then, comment out the part where the command \printbibsection is being defined. Below the sorting scheme definition add

\newcommand*{\makebibcategory}[2]{\DeclareBibliographyCategory{#1}\defbibheading{#1}[#2]{\subsection*{#2}}}
\makebibcategory{books}{Books}
\makebibcategory{papers}{Refereed research papers}
\makebibcategory{chapters}{Book chapters}
\makebibcategory{conferences}{Papers in conference proceedings}
\makebibcategory{techreports}{Unpublished working papers}
\makebibcategory{bookreviews}{Book reviews}
\makebibcategory{editorials}{Editorials}
\makebibcategory{phd}{PhD thesis}
\makebibcategory{subpapers}{Submitted papers}
\makebibcategory{curpapers}{Current projects}

\newcommand*{\printbib}[1]{\printbibliography[sorting=chronological,category=#1,heading=#1]}

By the way, I changed the \defs to \newcommands, because of this tip.

Then, in the preamble of your actual CV file (I again based it on Friggeri's template), just add the command \addbibresource{example.bib} to add your .bib file (this command replaces the \bibliography command in recent versions of biblatex).

Under the section Publications, take out everything and add

\nocite{*}
\addtocategory{books}{Griebel.etal-Numericalsimulationin1998}
\addtocategory{papers}{Akervik.etal-Globaltwo-dimensionalstability2008}
\addtocategory{chapters}{Grisvard-Ellipticproblemsin1985}
\addtocategory{conferences}{Rham.Albone-EvolutionaryFarField1196}
\addtocategory{techreports}{Abdulrahim.Cocquyt-Developmentofmission-capable2000,Adoua.etal-Reversaloflift2009}
\addtocategory{bookreviews}{Skalak.Kucera-notecouplingof2004}
\addtocategory{editorials}{Sverak-LandausSolutionsNavier2011}
\addtocategory{phd}{Grote-Nonreflectingboundaryconditions1995}
\addtocategory{subpapers}{Sohr-specialclassof1999}
\addtocategory{curpapers}{BVPswithsingularitiesinphasevariables}

\printbib{books}
\printbib{papers}
\printbib{chapters}
\printbib{conferences}
\printbib{techreports}
\printbib{bookreviews}
\printbib{editorials}

Of course, you'll want to adapt your keys to what makes sense in your case. This patchwork of Friggeri's and your own propositions seems to work decently over on my side. Tell me how it works.

  • Hi, This seems to work, but when running biber I am told Cannot find control file '(lastname).tex.bcf'! - did you pass the "backend=biber" option to BibLaTeX? That's a bit confusing since my .cls has been updated to do that, here's the revelant snippet: \RequirePackage[style=verbose, maxnames=99, sorting=ydnt, backend=biber]{biblatex} – Greggarious Feb 6 '14 at 19:15
  • Realized I should have been running biber cvsources' (since bib file is cvsources.bib. But I still get the same error biber ./cvsources INFO - This is Biber 1.6 INFO - Logfile is './cvsources.blg' ERROR - Cannot find control file './cvsources.bcf'! - did you pass the "backend=biber" option to BibLaTeX? INFO - ERRORS: 1' – Greggarious Feb 6 '14 at 19:25
  • Hmm, I never encountered that error. I guess you tried to delete everything but the .bib and the .tex? I'm running biber 1.8, biblatex 2.8a and XeTeX 3.1415926-2.5-0.9999.3-2013103115 (TeX Live 2013/Debian). – Christoph B. Feb 6 '14 at 20:37
  • Yeah... to clarify, you would run xelatex (filename); biber (filename); then run xelatex again twice, right? Maybe I'm just giving the wrong file name to biber - should it be the name of the .tex or the .bib? Should I leave on the file extension? – Greggarious Feb 8 '14 at 2:59
  • Oh, I think I've got it. I've got a file test.tex and my sources are in ref.bib, which is referenced in the .tex file by the \addbibresource command. Then I run xelatex test.tex, followed by biber test (no extension, and certainly not biber ref!), and xelatex test.tex again. Does that work? – Christoph B. Feb 8 '14 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.