When I click View in Aquamacs after clicking Latex, it opens TexShop and a TexShop viewer. I want it to open Skim. I have set preferences to Skim as per other posts on this site. This behavior happens with some latex files but not others, meaning for some the viewer does open as Skim and for some as TexShop. Could you advise on how I can make it always be Skim? Why would it differ depending on the latex file?

As an orthogonal question, I could live with TexShop preview if it did automatic updates. From other posts I understood that for that I needed only to check the Automatic Preview Update option in the preview preferences and re-start TexShop, which I did, but when TexShop opens under Aquamacs, it will not automatically update.


  • Have you set the file to open in Skim in the Finder? If so you also have to choose the option in the info window that says apply to all files of this type. This is an MacOS thing and it sounds like Aquamacs is respecting whatever setting it finds on a file by file basis. Feb 1, 2014 at 4:37
  • Geoff, Finder showed pdf files as set to open with Preview.app. I changed this to Skim, and also applied to all files of this type via info, and then did latex and view again in Aquamacs, but it still opens TexShop. Thanks, Rohit Feb 1, 2014 at 5:03
  • BTW: Welcome to TeX.SX! Feb 1, 2014 at 5:45
  • I seem to have resolved this by just copying my latex file to a temp file, deleting the original, and copying back. And now view invokes Skim. I'd still be curious as to how something like this could happen. Feb 1, 2014 at 17:05
  • I have had the same problem this morning, but it was only with one file that was created in other computer, with Linux/Texworks. Can it be some kind of problem with the encoding of the TeX file that prevents Skim from opening the PDF generated by compiling it? I have also Skim as my default viewer for LaTeX files in the Finder. if I double-click the PDF file outside Aquamacs, it is opened with Skim.
    – user45423
    Feb 4, 2014 at 19:23

1 Answer 1


I had this same problem. I have a common Dropbox with someone else. Apparently he had set the default compiler to be latex --> dvips, as opposed to pdflatex. Aquamacs called TeXShop to deal with the ps output. The problem was solved by switching to pdflatex via selecting "Generate PDF" under TeXing options in the Command menu.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .