1

I tried to install MyriadPro using FontPro (FontPro). Everytime I try to compile a latex document with pdflatex I get the following error:

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+597/600 --dpi 597 MyriadPro-Bold-tosf-t1--base
mktexpk: don't know how to create bitmap font for MyriadPro-Bold-tosf-t1--base.
mktexpk: perhaps MyriadPro-Bold-tosf-t1--base is missing from the map file.

I had no problems installing MinioPro the same way.

Any ideas?

I used the following commmands:

$ git clone https://github.com/sebschub/FontPro.git
$ cd FontPro
$ mkdir otf
$ cp /Applications/Adobe\ Reader.app/Contents/Resources/Resource/Font/*.otf otf
$ ./scripts/makeall MyriadPro  

There were a lot of message of the following form: tlf-ly1,warning: kpathsea: configuration file texmf.cnf not found in these directories: /opt/local/etc/texmf.

But those messages also appeard when I successfully installed MinionPro

$ sudo ./scripts/install /usr/local/texlive/texmf-local/
$ sudo updmap-sys --enable Map=MyriadPro.map

Resulting in the following output (same with MinionPro):

updmap: resetting $HOME value (was /Users/chris) to root's actual home (/var/root).
updmap is using the following updmap.cfg files (in precedence order):
  /usr/local/texlive/2013/texmf-dist/web2c/updmap.cfg
updmap is using the following updmap.cfg file for writing changes:
  /usr/local/texlive/2013/texmf-config/web2c/updmap.cfg
updmap: top config file /usr/local/texlive/2013/texmf-config/web2c/updmap.cfg has not been read. at /usr/texbin/updmap line 1334.

EDIT: I just found out that MinionPro is not installed properly. The compiled PDFs look "pixelated".

  • Please tell us which commands you used. Just saying you followed that isn't very specific as it covers several different options even for a single OS. For example, did you use updmap or updmap-sys? Did you use sudo or run as root or run as yourself? Did you get any errors? Which texmf tree did you install into? Etc. – cfr Feb 2 '14 at 4:38
  • The installation script appears to be looking for your installation of TeX in /opt whereas it is almost certainly in /usr/local/texlive. I'm not sure why the updmap.cfg is not read. Does that file exist on your system? It may not be an error if not if you've not installed any additional fonts before. – cfr Feb 2 '14 at 17:33
  • Try ./scripts/makeall --help to see if there's an option allowing you to specify the correct location for the TeX installation. – cfr Feb 2 '14 at 17:34
  • Why are you using pdfTeX with (presumably) OpenType fonts in 2014 when you can use XeTeX and LuaTeX which make font installation much easier? – Reinstate Monica - M. Schröder Feb 3 '14 at 8:49
  • 1
    @MartinSchröder: Because pdflatex offers full microtype support. – Sugor Feb 4 '14 at 2:41
0

I think this is a bug, or an error in the install directions, as I had the same result. Only, I managed to get MinionPro installed using FontPro, and it works amazing. Tried more or less the same thing with MyriadPro, and get exactly the same error about MyriadPro-Bold... is missing.

Not the answer you're looking for? Browse other questions tagged or ask your own question.