6

Whenever I try to compile my .tex file, I get the following error:

! LaTeX Error: File ngerman.sty not found. Type X to quit or to proceed, or enter new name. (Default extension: sty) Enter file name: ! Emergency stop. l.3 \begin

Here's a MWE:

\documentclass[a4paper,12pt]{article}
\usepackage{ngerman}
\begin{document}
xyz
\end{document}

This happens even though the ngerman.sty package can be found in the following directories:

  • /usr/share/texlive/texmf/tex/latex

  • /usr/share/texmf/tex/latex

I also tried running the texhash command.

  • Did you run texhash as root? – Sigur Feb 2 '14 at 15:56
  • 3
    ngerman is absolutely obsolet. You should use babel with the language option ngerman – Marco Daniel Feb 2 '14 at 15:58
  • As your document seems to find article.cls: Where is it according to the log-file? – Ulrike Fischer Feb 2 '14 at 15:58
  • 3
    @Jurg, use the terminal to install texlive-lang-german – Sigur Feb 2 '14 at 16:04
8

Open a terminal (ctrl + alt + t) and run the following commands:

  1. sudo add-apt-repository ppa:texlive-backports/ppa
  2. sudo apt-get update
  3. sudo apt-get install texlive-lang-german

 (4.) sudo apt-get upgrade

  • I guess that you don't need (6). – Sigur Feb 2 '14 at 16:14
  • I think it doesn't do any harm, but I'll put it in brackets as it's not really necessary. :) – Jurg Feb 2 '14 at 19:44
  • Changed to (4.). – Speravir Feb 2 '14 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.