2

In relation to this question, I'd like to get a fancy header just on the first page of my scrartcl document (height about 150 pts), but even using \thispagestyle{myfancyhdr} all the following pages display a big blank empty header, without any picture, pushing the whole content downwards, although the main style is plain or empty.

I don't want it! Is there any way to avoid it?

My code is

\documentclass[11pt]{scrartcl}
\pagestyle{empty}

[...]

\usepackage[...]{classicthesis}
\usepackage{arsclassica}

\usepackage{fancyhdr}
\fancypagestyle{ciccio}{%
%\fancyhf{} 
\renewcommand{\headrulewidth}{0pt}
\fancyhead[L]{}
\fancyhead[R]{
\includegraphics[width=3cm
]{strathlogo}
}
}

\begin{document}

\thispagestyle{ciccio}

[...]

\end{document}
  • 3
    When working with a class from »KOMA-cript« you should better use its »scrpage-scrlayer« package (or the older »scrpage2«), but not »fancyhdr«. – Thorsten Donig Feb 3 '14 at 9:40
  • I agree with @ThorstenDonig. Nevertheless, I’m not sure what is your actual problem. (Your MWE is neither minimal nor working.) You specify \pagestyle{empty} in the beginning. I would always put \pagestyle after \usepackage{fancyhdr} and it seems you rather want \pagestyle{ciccio}, because \thispagestyle{ciccio} only applies to a single page. You’ll probably also want to add \setlength{\headheight}{105pt} to your preamble. – Crissov Feb 3 '14 at 11:24
  • BTW: Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – karlkoeller Feb 3 '14 at 11:48
  • Does the answer solve your problem? Or you need some more help? – karlkoeller Feb 4 '14 at 8:54
  • Yes, everything's fine now! Sorry I still have to understand how the site works. I wanted to post a big THANKS to your reply! My assignment looks really cool now, the solution works perfectly, your example was so clear. Btw the 11 pts are going to be changed according to my lecturers' requests, that's why. – derbo Feb 5 '14 at 15:45
4

The package fancyhdr works bad when using KOMA classes.

You should use scrpage-scrlayer (or the older scrpage2) instead of it.

Your fancyhdr code for defining the new style ciccio can be replaced by this one:

\deftriplepagestyle{ciccio}
    {}
    {}
    {\includegraphics[width=3cm]{strathlogo}}
    {}
    {\pagemark}
    {}

In the following MWE I've added height=1cm just for displaying purposes, remove it in your document.

\documentclass[11pt]{scrartcl}
\usepackage[demo]{graphicx}
\usepackage{lipsum} % only for the example

\usepackage{scrlayer-scrpage}

\deftriplepagestyle{ciccio}
    {}
    {}
    {\includegraphics[width=3cm,height=1cm]{strathlogo}} %remove the height option in your doc
    {}
    {\pagemark}
    {}

\pagestyle{empty}

\begin{document}

\thispagestyle{ciccio}

\lipsum[1]

\newpage

\lipsum[1]

\end{document} 

Output:

enter image description here

If, with your image, you get a warning about \headheight too low, you'd better adjust the \headheight too.

  • Just a remark: The package option 11pt could be left out, it’s the default for KOMA-Script. – Speravir Feb 3 '14 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.