10

I am using Fedora 19, TexMaker and TeX Live. When I tried to compile my .tex document, I got the following error:

! LaTeX Error: File `stmaryrd.sty' not found

I found out that the file is a part of texlive-math-extra package. When I tried to install the package using the command

yum install texlive-math-extra

I get the following response:

No package texlive-math-extra available

Could anyone, please, tell me, how I can install the package? Or what might be the problem with my way of installation

P.S. I have the same story with texlive-latex-extra package
P.S. Just copying the required .sty files to home/texmf/tex directory does not help me because I also need some other files from the packages

3
  • Do you need root privileges to install?
    – Johannes_B
    Feb 4, 2014 at 15:11
  • 1
    Fedora (18) TexLive (2012): texlive-collection-mathextra Did you mispell?
    – Johannes_B
    Feb 4, 2014 at 15:13
  • 3
    Well, in all honesty, just install the TeXlive from TeX's official sources and not from Fedora's ones. You'll save yourself a lot of troubles like this one. The way how TeXlive gets into the distros is very unfortunate. Useful link: tug.org/texlive/acquire-netinstall.html
    – yo'
    Feb 4, 2014 at 15:43

3 Answers 3

6

It seems that in 2018 the package is now called texlive-science.

4

The fedora package is called texlive-collection-mathextra

1

Thank you very much for the help! I Have found the solution. The command for the installation is just

yum install stmaryrd and yum install subfigure (for my second issue).

Texlive-mathextra indeed contains stmaryrd.sty (I saw it) as it is suggested here: http://gentoo.2317880.n4.nabble.com/which-package-contains-latex-stmaryrd-sty-td139586.html and here: http://ubuntuforums.org/archive/index.php/t-1040608.html. But all the forums where they suggest to install this package are dedicated to Ubuntu while I have Fedora. Probably, that was the reason.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .