0

I tried to install the package mathalfa using the package manager (admin), it supposed that clicking on the plus sign everything is done, but when I call the package in my tex file and use the commands that are part of that package, MiKTeX cannot compile it and it tells "undefined control sequence". What I need to do?

  • 1
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Speravir Feb 6 '14 at 2:56
  • Did you by any chance once have used the user update? Because it looks like you need to update the FNDB as user. And you also will have to do this in future for every update the admin does. – Speravir Feb 6 '14 at 3:01
  • Shouldn't it complain the package isn't found in that case? [Note: I know zilch about MiKTeX.] – cfr Feb 6 '14 at 4:22
  • Show a complete minimal example that demonstrates the problem and the log-file of this example. @Speravir: If one use the package manager to install it shouldn't be necessary to update the FNDB. But it is quite possible that the package is already installed in the User root and hides the (newer) admin version. In this case one should run the update manager (as user). – Ulrike Fischer Feb 6 '14 at 9:06
  • @lalo See Ulrike’s comment above. And as addition to my first remarks: Difference between administrative and user mode of MiKTeX. – Speravir Feb 6 '14 at 15:17
1

This usually happens because you did not refresh the database. To refresh the database of the packages, do the following:

  1. open MiKTeX options (from your start menu)

  2. In the General Tab (click on refresh FNDB).

  3. Recompile your file, it should work by now.

    • If you are running a portable version of MiKTeX, follow these procedures:

      1. In the Miktex folder, open the file named (miktex-portable.cmd)
      2. In the notification area, there will be a MiKTeX icon, right click on it and then choose MikTeX options.
      3. In the General Tab (click on refresh FNDB).
      4. Recompile your file, it should work by now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.