I want to use ytableau package. I was using MikTex 2.8 and after trying to compile I recieved a message that it would not be possible to download packages for MikTex 2.8 any more. So, I have installed MikTex 2.9 with the option of on-the-fly installation assigned and it did not work. MikTex still complains about not having found the package and it does not even try to download it from internet. So I opened the package manager, selected the package and clicked on install (inside task menu). Apparently, it installs the package, but guess what happens when I run LaTeX... It still does not find that package. What am I supposed to do?


The reason is that, as happens from time to time with MiKTeX packages, it isn't really installed: you have the doc and the source files. So you have to extract the archive, preferably outside of the MiKTeX tree, which will contain a "source" directory with a ytableau-src.tar.bz2. Extract this one ; you'll then get a source\latex\ytableau directory that contains two files: ytableau.dtx and ytableau.ins.

Compiling ytableau.ins with latex will produce from ytableau.dtx a ytableau.sty file. Move it to \MiKTeX 2.9\tex\latex\ytableau\ (or maybe your local TeX root\tex\latex\ytableau\, since it was not installed by the distribution). All that remains to do is to refresh the FNDB.

Edit: The bug is fixed with the 2014/2/19 update, cf. bug tracker entry Package ytableau incomplete.


Have you clicked on the "Refresh FNDB" button in the MiKTeX Options application? I always had to do that after installing a new package with MiKTeX 2.8 before it could be found. I have not had to do any manual installs with MiKTeX 2.9 - the "on the fly" option seems to be working OK for me.

What are you using to invoke MiKTeX by the way? I use TeXnicCenter. I am trying to recall if I had to do anything when I upgraded MiKTeX, and I can't think of anything specific, other than changing the path to point to MiKTeX 2.9 in TeXnicCenter, but if I think of anything else I'll post back!

Incidentally, the MikTex Options "Roots" panel suggests that it is searching
C:\Program Data\MikTex2.9\ and
C:\Program Files\MikTex 2.9\
but I was searching for my recently installed packages earlier and eventually found them in
This might give you somewhere to look to check whether it installed correctly?

  • You looked in MiKTeX Settings for Admin first. This does only see these two directories. the other is user specific. See also Difference between administrative and user mode of MiKTeX. – Speravir Feb 6 '14 at 15:44
  • Ah, ok. I always use the Admin but I guess thinking about it it's obvious that it wouldn't point to individual user profiles. I also didn't expect it to install packages in a user-related way, but then I don't know much about windows ;-) – FionaSmith Feb 6 '14 at 15:49
  • When you really only use admin mode, then I wonder as well. – Speravir Feb 6 '14 at 15:54
  • I don't know what you mean. Incidentally, I just tried running the non-Admin version and it just threw up an error. Reminded me why I have always used the Admin version. We're not all computer experts you know! – FionaSmith Feb 6 '14 at 16:08
  • Because the admin mode does not know any of the user directories, it cannot install in of them. – Speravir Feb 6 '14 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.