1

I'm on Debian 7.3 KDE desktop with Kile v. 2.1.0, the editor for LaTeX. I installed it from the repos without the LaTeX-related recommended packages, after 'manually' installing TeXLive from a CTAN mirror. I'm still getting used to Kile's way of working but I want it to stop automatically adding another quote mark after I type this character:', thus making it look like a double quote:". I tried to turn it off by going to Settings > Configure Kile > General > un-tick "Automatically insert opening & closing double quotes for LaTeX". I actually like this feature when I need to open and close double quotes for dialogues (He said:``Let's get a drink!") but it's working against me, now. How do I correct it? Is there a file somewhere (~/.config/kile... maybe?) that I have to touch up?

EDIT: I've added a picture below. Do you people have the same view of Configure Kile > Complete ? I think I have a bugged version of Kile. enter image description here

  • 1
    I don't know how to switch it off but I can tell you that you can safely re-enable "Automatically insert opening and closing double quotes for LaTeX". It really only takes care of double quotes. I have it enabled and my Kile does not show the behaviour you describe. Did you look for a weird extension that might be doing this? – Christian Feb 6 '14 at 15:03
  • 2
    I don't see this behaviour with Kile 2.1.3. – StrongBad Feb 6 '14 at 15:05
  • I don't see this behavior with Kile 2.1.0, actually. (I'm on Kubuntu but I wouldn't think that would matter.) So it must be something in the configuration, or an extension, or something like that. – David Z Feb 6 '14 at 15:57
  • In Configure Kile > Extensions I have this list of plugins: AutoBrace [], Data Tools [], Exporter [x], Highlight selection[x], IconInserter[], Insane (not ZEN) HTML coding[], Insert File[]. Only 2 of them are selected (hence the [x]). What could it be? – WobblyWindows Feb 6 '14 at 17:02
  • Anyone has my same view of Configure Kile > Complete? See picture above... – WobblyWindows Feb 7 '14 at 20:18
1

Thanks to user cfr for suggesting this work-around (see discussion here)!

To solve the double quote effect of ' mark, go to Settings menu > Configure Kile > Editor > Editing > Auto-Brace plugin. Select it and click on its configuration button, on the right. Un-check the option "Automatically add closing quotation marks". A msg box will pop-up telling you The autobrace plugin supersedes the Kate-internal AutoBrackets feature. The setting was automatically disabled for this document. This solved the problem of Kile automatically adding an extra ' mark every time I wanted to type I'm or it's, however now it DOESN'T automatically close brackets as it used to. This is a problem since I often need nested brackets in math environments. Maybe I'll have to un-check the other check-box too, in the configuration dialogue box of the AutoBrace plugin...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.