4

I'm not sure if this question has been asked here or not; a quick search didn't reveal anything, but maybe I didn't use the correct terminology (regardless, I apologize if it is a duplicate).

I'm not certain why, but last night while at home, I was able to compile my .tex document without a problem and get a .pdf file (if it's relevant, this was in WinEdt 8). When I came into my office today and started working on the .tex file again, I click the PDFTeXify button, and no .pdf file is produced (my office computer has WinEdt 7). In the PDFTeXify compilation report, no errors or warnings are listed, but there aren't any pages output.

This is the first time I've had trouble with this, so I'm not sure how to address it. Any information and/or insight would be greatly appreciated!

closed as off-topic by Reinstate Monica - M. Schröder, jub0bs, Jesse, Gonzalo Medina, Svend Tveskæg Feb 8 '14 at 18:20

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Can you post a MWE? It's nigh impossible to know the problem with nothing to go off of. – Sean Allred Feb 7 '14 at 14:31
  • @SeanAllred: I think the problem lies in the title. If I reduce the file name to Notes, then the .pdf compiles correctly. Has WinEdt improved their compatibility with spaces in files names? – Clayton Feb 7 '14 at 14:44
  • That would definitely do it, and apparently they haven't. – Sean Allred Feb 7 '14 at 15:23
  • @SeanAllred: That is precisely it...perhaps in WinEdt 8 they have installed some updates to allow this feature, whereas the updates are not available in WinEdt 7... Thanks for your help! – Clayton Feb 7 '14 at 15:47
  • 4
    This question appears to be off-topic because it can be solved by updating the software (WinEdt/MikTeX). – Reinstate Monica - M. Schröder Feb 8 '14 at 17:19
10

This problem has nothing to do with WinEdt 7.

WinEdt 7 is able to treat filenames with spaces as WinEdt 8 is.

The problem relies in the fact that WinEdt launches compilers with the command line option --synctex=-1.

Older version of SincTeX didn't have support for filenames containing spaces.

I'm sure that at work you have an older version of MiKTeX or TeX Live than at home, containing old versions of compilers which are built with old versions of SyncTeX.

You can solve this problem at work either using file names without spaces or deselecting the option Use --synctex switch when --src is enabled in WinEdt, which can be found in Options -> Execution Modes dialog, as shown in the picture below.

enter image description here

  • Is it possible to provide a version number/release date for Synctex "old versions of SyncTeX that does not support spaces in file names" and for "old versions of compilers" ? Which version number of Synctex supports spaces in file names ? Does the newest Synctex support special characters also ? – texenthusiast Feb 12 '14 at 2:47
  • @texenthusiast It depends on when the latest version of SincTeX has been incorporated in the executables. For example, so I can't give you an answer. In regards of special characters, it depends on the OS. If the OS supports file names with special characters (e.g. russian alphabet) then SincTeX is able to handle them. – karlkoeller Feb 12 '14 at 5:36
1

The problem lies in the name of the file: WinEdt 7 apparently doesn't have support for spaces in the name of the file, whereas WinEdt 8 does have that support.

  • 2
    This is wrong. WinEdt 7 has nothing to do with it. Since WinEdt 7 adds the command line option --synctex=-1 (same as v8) to the command line of the compiler, I'm quite sure that at work you have on old version of MiKTeX (or TeX Live) which does not have support for filenames with blanks when calling SyncTeX. – karlkoeller Feb 7 '14 at 16:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.