5

Consider the following MWE:

\documentclass[10pt,compress,
               xcolor={dvipsnames,table}
              ]{beamer}
%%%Beameroptions
 \usetheme{Luebeck}
 \usecolortheme{orchid}
 \usefonttheme{default}
 \useinnertheme{rectangles}
 \useoutertheme{default}
 \setbeamercovered{transparent}
\begin{document}

\begin{frame}{onslide}
\begin{tabular}{l c r}
\hline 
letter  & number & misc. \\
\hline
\onslide<1->{
A & 10 & ! \\
}
\onslide<2>{
B & 20 & ? \\[-\normalbaselineskip]
}
\\\hline
\end{tabular}
\end{frame}

\begin{frame}{onslide+}
\begin{tabular}{l c r}
\hline 
letter  & number & misc. \\
\hline
\onslide+<1->{
A & 10 & ! \\
}
\onslide+<2>{
B & 20 & ? \\[-\normalbaselineskip]
}
\\\hline
\end{tabular}
\end{frame}

\begin{frame}{onslide in every cell}
\begin{tabular}{l c r}
\hline 
letter  & number & misc. \\
\hline
\onslide<1->{A} & \onslide<1->{10} & \onslide<1->{!} \\
\onslide<2->{B} & \onslide<2->{20} & \onslide<2->{?} \\\hline
\end{tabular}
\end{frame}

\begin{frame}{pause}
\begin{tabular}{l c r}
\hline 
letter  & number & misc. \\
\hline
A & 10 & ! \pause\\
B & 20 & ? \\
\hline
\end{tabular}
\end{frame}
\end{document}

What I want to do is uncover a similar table in two steps. Unfortunately I face some problems with that. I have already read this and it does work fantastically. (I also followed these descriptions.)However, once I add \setbeamercovered{transparent} to the preamble it does not work anymore.

Instead of using the whole argument enclosed in \onslide<2->{ ... } only the contents of the first cell is displayed in transparent. I found a workaround here, using \onslide+<2->{ ... },which works fine, but not in the way I would like it to behave: Instead of displaying the argument transparent it is not displayed at all. I could live with this for the moment, but as itemize environments work just fine I would rather switch off transparency entirely. (\visible<2->{ ... } has the same effect. Using \invisible{ ... } is more complicated and has similar effects.)

Another problem arises with the alignment of the first column, but this might just be unfortunate and removed by commenting out line endings. I have not tried this yet because I wanted to focus on the other problem.

I also tried to workaround with putting \onslide<2->{ ... } in every cell, which works 'just' fine, but is a rather nasty workaround. While the example shows a very small table, the actual ones are much more complicated and I would prefer a simpler solution.

I have also tried the pause command, which produces two slides, that are exactly the same. Again if I remove the transparent option it works just fine (as it should).

I expect the problem to be similar to that described in section 23.4 with the alignment in formulas (the code is reprocessed several times, messing things up.). But I have no clue of the internals, hence cannot create a working solution. For that kind of thing was suggested a workaround, which is even more nasty than putting onslide in every cell. (See here.)

I browsed manual and the internet quite a bit but nothing led me to a satisfying conclusion. (Apart from those I already discussed.) Maybe someone can point me in the right direction. I am interested in some more convenient and more elegant solutions than the presented ones. Any ideas are very welcome.

2
  • It is a grouping problem related to the way \opaqueness is implemented. Unfortunately I don't see a simple work around. Your misalignment problem is simply an end of line outside of the \onslides that is needs to be commented out. Feb 25, 2014 at 15:40
  • @andrewswann I was afraid that this would happen. I have done some research and unfortunately came back with no solution whatsoever. I recently run into a similar problem with \alert<>{}, which does not compile at all. So this is really a colour related issue. At least i got the tumbleweed for this question. Thanks for your comment. Mar 18, 2014 at 9:59

1 Answer 1

4

Try updating. The following works fine in pdflatex from TeXlive 2016.

\documentclass[10pt,compress,
               xcolor={dvipsnames,table}
              ]{beamer}

\usetheme{Luebeck}
\usecolortheme{orchid}
\usefonttheme{default}
\useinnertheme{rectangles}
\useoutertheme{default}
\setbeamercovered{transparent}

\begin{document}

\begin{frame}{pause}
\begin{tabular}{l c r}
\hline 
letter  & number & misc. \\
\hline
A & 10 & ! \pause\\
B & 20 & ? \\
\hline
\end{tabular}
\end{frame}
\end{document}

enter image description here

2
  • Thank you very much. Since I have adjusted my presentation style to be different, I completely forgot. Do you have any idea about why it does work now? Feb 10, 2017 at 13:57
  • 1
    @Martin-マーチン Maybe some changes in beamer? Feb 10, 2017 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.