I am using MiKTeX 2.9 and XeLaTeX. Here is my minimal working example:

\setmainfont[Mapping=tex-text]{Times New Roman}
\newfontfamily{\cyrillicfonttt}{Courier New}


\title{TeX writer}
\extrainfo{\faSkype~ myskypelogin}


Skype Font Awesome symbol has been created like in this question. But for some strange reason it doen't work properly: result

What am I doing wrong? I have tried to replace "F17E with "F117 and it worked just fine.

  • Isn't it obvious? Update the font. Get the new otf from the fontawesome webpage. Btw: Don>'t load xunicode before xltxtra. – Ulrike Fischer Feb 8 '14 at 14:23

The font FontAwesome.otf in TeX Live (January 2014) has version 3.1.0:

$ otfinfo --font-version $(kpsewhich FontAwesome.otf)
Version 3.1.0 2013

However icons.yml shows that the glyph Skype was created in version 3.2:

- name:       Skype
  id:         skype
  unicode:    f17e
  created:    3.2
    - Brand Icons

The current version of FontAwesome is 4.0.3. It can be downloaded from the project home page.

Then the following LaTeX code should do:


Which font file is found by XeTeX?

XeTeX writes an extended DVI format that is converted by xdvipdfmx to PDF. If the latter program gets option -v (be verbose), then it prints the location of the font files that are used by it. Options can be passed to xdvipdfmx via option -output-driver of XeTeX:

xelatex "-output-driver=xdvipdfmx -v" test

Then the found font file with path is printed on the console.

| improve this answer | |
  • Thank you for your answer! Unfortunately, it doesn't work either. I'm not using TeX Live and have the latest version of FontAwesome. Also I have checked in some WYSIWYG-editors that the Skype symbol exists in the font. – Vladimir Panchenko Feb 8 '14 at 14:52
  • @VladimirPanchenko: Perhaps you have the font twice and the wrong version is found and used by XeTeX. – Heiko Oberdiek Feb 8 '14 at 15:11
  • I tried to unistall all Font Awesome fonts and install last version again. It didn't help at all. – Vladimir Panchenko Feb 8 '14 at 16:29
  • 1
    @VladimirPanchenko: You have to search for different font files. The font might be installed in the system and in the TeX installation. Installing a new version will not help, if there is an older version lying around to be found by XeTeX. – Heiko Oberdiek Feb 8 '14 at 16:38
  • Thank you, old font file in MiKTeX folder was the problem! – Vladimir Panchenko Feb 8 '14 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.