1

When using accented characters (e.g. ë) I get the following error:

Package inputenc Error: Unicode char \u8:ële not set up for use with LaTeX.

A minimal working example is given below.

To the best of my knowledge my .tex file is UTF-8 encoded (I'm using TextMate on OS X and the file command also says it's an UTF-8 file).

If I comment out the \moderncvstyle{casual} command, a PDF is generated without errors, but a blank space is printed instead of the ë character.

Any suggestions on how to solve this?

% minimal working example

\documentclass[11pt,a4paper,sans]{moderncv}

\moderncvstyle{casual}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[dutch]{babel}

\name{Richard}{Kranendonk}
\title{Curriculum Vitae}
\address{Somestreet 1}{1000 AA Somecity}
\phone[mobile]{01~234~567~89}                    
\email{myemail@isp.com}                                
\homepage{http://www.doesnotexist.com}                          
\photo[64pt][0.4pt]{Pasfoto_160x213}
\quote{Januari 2014}

\begin{document}

\cventry{1999}{Presentatie vaardigheden, Commerciële vaardigheden, Onderhandelen, Conflicthantering}{Kenneth Smit Communicatie Trainingen}{}{}{}

\end{document}

closed as unclear what you're asking by egreg, user31729, user13907, Andrew, Jesse Jul 16 '15 at 11:51

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    I get no errors. Are you sure that your file is UTF-8 encoded? – karlkoeller Feb 9 '14 at 15:05
  • 1
    I get the error precisely if I encode the file in Latin-1. Save it as UTF-8, or use the latin1 option for inputenc – egreg Feb 9 '14 at 17:01
  • Strange. Just to be sure I did a 'Save as..' with encoding set to UTF-8 in TextMate 2.0, still get the errors. I'll check if this is a known issue in TextMate. – Richard Kranendonk Feb 10 '14 at 10:00
  • Are you able to report any news? – Johannes_B Jun 14 '15 at 19:58
0

Not really. I found out I need different encoding for my iMac and MacBook to prevent the errors. Probably some different makeup of the environments. I decided to be pragmatic and uncomment one of these LaTeX commands depending on the machine I'm working on:

\usepackage[latin1]{inputenc}           % works on iMac
\usepackage[utf8]{inputenc}             % works on MacBook Air

Not the answer you're looking for? Browse other questions tagged or ask your own question.