2

I am using the tex style of SMC.

Above my reference, this appears:

6. * 
References

This instead of "6. References".

I am using their style and printing the bibliography with:

\bibliographystyle{IEEEtran}
\bibliography{paper}

I went to the .sty file and I found the following entries:

\bibliographystyle{IEEEtran}

\def\thebibliography#1{
  \section{References}\list
  {[\arabic{enumi}]}{
  \settowidth\labelwidth{[#1]}\leftmargin 1em
  \advance\leftmargin\labelsep
  \usecounter{enumi}
  }
  \def\newblock{\hskip .01em plus .01em minus .01em}
  \sloppy\clubpenalty4000\widowpenalty4000
  \sfcode`\.=1000\relax
}

\let\endthebibliography=\endlist

\long\def\@makecaption#1#2{
  \vskip 10pt
  \setbox\@tempboxa\hbox{#1. #2}
  \ifdim
    \wd\@tempboxa >\hsize #1. #2\par
  \else
    \hbox
    to\hsize{\hfil\box\@tempboxa\hfil}
  \fi
}

I notice the problem dissapears when I comment \uspackage{amsmath}. I have tried adding \usepackage{amsrefs}, but that says the bib environment is already defined.

Here is a min working example and a link to the style file.

\documentclass{article}



\usepackage{icmcsmc2014}

 \usepackage[numbers]{natbib}
\usepackage{amsmath}


\begin{filecontents}{paper_test.bib}
@article{herremans2013composing,
  title={Composing Fifth Species Counterpoint Music With A Variable Neighborhood Search Algorithm},
  author={Herremans, Dorien and S{\"o}rensen, Kenneth},
  journal={Expert Systems with Applications},
  volume={40},
  number={16},
  pages={6427--6437},
  year={2013},
  publisher={Pergamon}
}
\end{filecontents}


\usepackage{times}
\usepackage{ifpdf}
\usepackage[english]{babel}
% \usepackage{cite}
%   \usepackage{multibib}



% ***************************************** the document starts here ***************
\begin{document}



\section{Introduction}

Here I want the author name to occur with citet as it is said by \citet{herremans2013composing}.

%   \bibliographystyle{IEEEtran}
%   \bibliographystyle{natbib}
  \bibliography{paper_test}


\end{document}
  • Please add a complete, minimal document allowing us to reproduce the problem. A link to the document class used (in case it's not found on CTAN) would also be useful. – Gonzalo Medina Feb 10 '14 at 18:07
  • You are right. I have added this. – dorien Feb 19 '14 at 8:44
  • Thnaks for adding the example. I've provided an answer below. – Gonzalo Medina Feb 19 '14 at 13:29
2

The file icmcsmc2014.sty internally uses the IEEEtran style for the bibliography and this style is incompatible with natbib. You have two options:

  1. Do not load natbib and use the defualt IEEEtran style for your bibliography (or course, now you cannot use \citet and the family of commands provided by natbib):

    \documentclass{article}
    \usepackage{icmcsmc2014}
    \usepackage{amsmath}
    \usepackage{times}
    \usepackage{ifpdf}
    \usepackage[english]{babel}
    
    \begin{filecontents}{paper_test.bib}
    @article{herremans2013composing,
      title={Composing Fifth Species Counterpoint Music With A Variable Neighborhood Search Algorithm},
      author={Herremans, Dorien and S{\"o}rensen, Kenneth},
      journal={Expert Systems with Applications},
      volume={40},
      number={16},
      pages={6427--6437},
      year={2013},
      publisher={Pergamon}
    }
    \end{filecontents}
    
    \begin{document}
    
    \section{Introduction}
    Here I want the author name to occur with cite as it is said by \cite{herremans2013composing}.
    
    \bibliography{paper_test}
    
    \end{document}
    

    enter image description here

  2. If you want to use natbib and its family of citation commands, then go to line 228 of icmcsmc2014.sty and comment out the line \bibliographystyle{IEEEtran}. Now you can load natbib and you need to choose a natbib-compatible style for your bibliography in your document; in the example below I used plainnat. The other important thing is that you need to load natbib before icmcsmc2014.sty:

    \documentclass{article}
    \usepackage[numbers]{natbib}
    \usepackage{icmcsmc2014}
    \usepackage{amsmath}
    \usepackage{times}
    \usepackage{ifpdf}
    \usepackage[english]{babel}
    
    \begin{filecontents}{paper_test.bib}
    @article{herremans2013composing,
      title={Composing Fifth Species Counterpoint Music With A Variable Neighborhood Search Algorithm},
      author={Herremans, Dorien and S{\"o}rensen, Kenneth},
      journal={Expert Systems with Applications},
      volume={40},
      number={16},
      pages={6427--6437},
      year={2013},
      publisher={Pergamon}
    }
    \end{filecontents}
    
    \begin{document}
    
    \section{Introduction}
    Here I want the author name to occur with citet as it is said by \citet{herremans2013composing}.
    
    \bibliographystyle{plainnat}
    \bibliography{paper_test}
    
    \end{document}
    

enter image description here

  • Thanks for the answer. Is there any solution where I don't modify the sty file? As this is the conference's style, they will probably use the original .sty file. – dorien Feb 19 '14 at 14:28
  • In any case, loading natbib before the template already solves my section title problem. Would be nice if I could fix the authors without editing the sty file. – dorien Feb 19 '14 at 14:33
  • @dorien If they are going to use the original .sty file, then don't use natbib and its citation commands. as I mentioned in the first option. Most probably they want the citations to appear according to the IEEEtran style. – Gonzalo Medina Feb 19 '14 at 14:34
  • Yes, I do understand that. Sometimes it is useful to get the author's name printed though (even without the reference), when refering to who said something. I am not so fond of "[2] said", but I guess if there is no way, this will have to do. Your answer was very enlighting though! – dorien Feb 19 '14 at 14:38
  • Opted for your second solution in the end : ) Thanks! Hope the submission system accepts pdf : ) – dorien Feb 19 '14 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.