I am writing my thesis in LyX using classicthesis and have some troubles with citation style.

Basically, I want to avoid ERT when citing and instead use LyX' built-in "Insert citation" to get Author-comma-year instead of Author-year (see image for details. Left: Output, Right: LyX input).


I use the following Document Settings:

Document class: Classicthesis

Class option:


Citation Style: Natbib; Author-year ('Numerical' is the only other option)

Bibliography style: abbrvnat

In preamble:

% Citep


I am aware that similar questions have been raised, however, those threads have not solved my problem.

  • is that "autheryear" in the second line of the preamble on purpose or a typo? Feb 3, 2019 at 18:13

1 Answer 1


Your problem is abbrvnat. Choose apalike, authordate1, ..., authordate4 or chicago instead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .