12

This is a continued question from my previous thread I am setting up LaTeX to write my thesis using scrreprt.

I have implemented with success all the advised and suggested solutions and have tried to tinker to achieve the final desired aesthetic change which was increasing the chapter name size.

Currently I am more than happy with the size of the chapter and chapter number, but I wasn't able to figure out the right way to control the chapter name. I used \addtokomafont{chapter}{\Huge} but could see no big change. I couldn't work out how to use a \scalebox. I also looked into using the \othersectionlevelsformat{sectioning name }{}{counter output } the KOMA-Script manual states on pg 97 that \renewcommand can be used to define formatting commands and that the original definitions in the KOMA-Script classes are:

\newcommand*{\partformat}{\partname~\thepart\autodot}
\newcommand*{\chapterformat}{%
\chapappifchapterprefix{\ }\thechapter\autodot\enskip}
\newcommand*{\othersectionlevelsformat}[3]{%
#3\autodot\enskip}

However I wasn't able to make use of this command effectively, could you please help, thank you in advance.

Please find below my current MWE, thank you in advance for any help.

\documentclass[
bibliography=totoc,
headings=big,
captions=tableheading,
chapterprefix=true% like in standard class "report"
]{scrreprt}
\usepackage[left=2cm,right=2cm,top=2.5cm,bottom=3cm]{geometry}
\usepackage{xcolor}
\usepackage{graphicx}
\usepackage{minitoc}
\usepackage{setspace}

\setcounter{secnumdepth}{3} % number subsubsections
\setcounter{tocdepth}{3} % list subsubsections

\begin{document}
\dominitoc
\tableofcontents

\addtokomafont{chapterprefix}{\raggedleft}

\addtokomafont{section}{\huge}
\addtokomafont{subsection}{\Large}
\addtokomafont{subsubsection}{\large}

\renewcommand*{\chapterformat}{%
\mbox{\scalebox{1.5}{\chapappifchapterprefix{\nobreakspace}}%
\scalebox{4}{\color{gray}\thechapter\autodot}\enskip}}

\setcounter{chapter}{6}\setcounter{page}{199}
\newpage\setcounter{page}{212}

\chapter{Conclusions}
\dictum[Sun Tzu]{If you know the enemy and you know yourself %\\
you need not fear the results of a hundred battles.}

\minitoc

\section{Summary of Achievements}
Text goes here

\subsection{Papers Submitted}
Text

\subsubsection{I want to go into the TOC}
Testing stuff out

\bibliographystyle{plain}
\bibliography{bibliography}

\end{document}
14

Load the lmodern package so you can use very huge sizes, then use something like

\addtokomafont{chapter}{\fontsize{30}{38}\selectfont}

and this is the result:

enter image description here

Complete MWE:

\documentclass[
bibliography=totoc,
headings=big,
captions=tableheading,
chapterprefix=true% like in standard class "report"
]{scrreprt}
\usepackage[left=2cm,right=2cm,top=2.5cm,bottom=3cm]{geometry}
\usepackage{xcolor}
\usepackage{graphicx}
\usepackage{minitoc}
\usepackage{setspace}
\usepackage{lmodern}

\setcounter{secnumdepth}{3} % number subsubsections
\setcounter{tocdepth}{3} % list subsubsections

\begin{document}
\dominitoc
\tableofcontents

\addtokomafont{chapterprefix}{\raggedleft}
\addtokomafont{chapter}{\fontsize{30}{38}\selectfont}
\addtokomafont{section}{\huge}
\addtokomafont{subsection}{\Large}
\addtokomafont{subsubsection}{\large}

\renewcommand*{\chapterformat}{%
\mbox{\scalebox{1.5}{\chapappifchapterprefix{\nobreakspace}}%
\scalebox{4}{\color{gray}\thechapter\autodot}\enskip}}

\setcounter{chapter}{6}\setcounter{page}{199}
\newpage\setcounter{page}{212}

\chapter{Conclusions}
\dictum[Sun Tzu]{If you know the enemy and you know yourself %\\
you need not fear the results of a hundred battles.}

\minitoc

\section{Summary of Achievements}
Text goes here

\subsection{Papers Submitted}
Text

\subsubsection{I want to go into the TOC}
Testing stuff out

\bibliographystyle{plain}
\bibliography{bibliography}

\end{document} 
  • 1
    lmodern loads another font. I think fontenc is enough. – Marco Daniel Feb 11 '14 at 18:54
  • Thank you for your reply it works, the font is not a big issue both are quite pleasing, much appreciated for the clear explanation. Have a nice day! – Fiztban Feb 11 '14 at 19:19
  • 1
    @Marco If I load fontenc and not lmodern the font look quite different. Do you notice the same behavior or there is something strange in my distro? – karlkoeller Feb 11 '14 at 19:34
  • 1
    @MarcoDaniel It seems that the T1 options of fontenc breaks the \sffamily\bfseries used by KOMA classes. Can you confirm? – karlkoeller Feb 11 '14 at 20:15
  • 1
    @karlkoeller: I can confirm it too. – Marco Daniel Feb 12 '14 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.