I am on a mac and I believe I am using MacTeX. I am getting errors of the sort:

File `fullpage.sty' not found.

When I run locate fullpage.sty I get


But when I run kpsewhich fullpage.sty I get nothing. I have already tried sudo texhash and sudo mktexlsr to no avail. I think the problem may be that I have two conflicting TeX Live versions installed—I recently installed QuTIP and I think during the process a basic version was installed via macports—but of this I am not certain. I have no idea how to proceed.

I have two questions: How can I get LaTeX to find fullpage.sty? And, if someone can see the real cause of the above error or knows how to find it, how can I remedy the situation?

  • 1
    There should be a pane in System Preferences to choose your active TeX Distribution. Please check its setting. – Crissov Feb 13 '14 at 13:36
  • Hi Crissov. Thank you for your reply. In the TeX Distribution pane only one option is shown: TeXLive-2013. Underneath it reads: “Full TeX Live 2013 Distribution.” This option has two suboptions ‘Intel 64’ or ‘Universal’. Unfortunately, selecting neither suboption solved my problem. Plowman. – P. Plowman Feb 13 '14 at 13:43
  • 1
    You can check what your system thinks it should search with kpsewhich --var-value TEXMFMAIN (works on Linux, at least). The command returns this line for me: /usr/local/texlive/2013/texmf-dist – jon Feb 13 '14 at 14:51
  • Hi jon. kpsewhich --var-value TEXMFMAIN returns /opt/local/share/texmf-texlive. It seems this is wrong? Should I get /usr/local/texlive/2013/texmf-dist? – P. Plowman Feb 13 '14 at 14:56
  • (If you use @<name> that person gets pinged.) Sounds odd given where your fullpage.sty file is. Have you set your paths correctly? If I issue echo $PATH, one of the items returned is an item that corresponds to the output of which kpsewhich. (Note: I'm only operating on the assumption that Macs mimic *nix setups on this sort of stuff; seems like it does, but someone else should know better the degree of overlap.) – jon Feb 13 '14 at 18:08

Old question, but this is a common problem. If you installed via MacTeX, TeX Live will end up in /usr/local/texlive, but I believe MacPorts installs under /opt by default (it did last time I checked, but it's been a few years). Hence, you do indeed have two conflicting TeX distributions, and you're running kpsewhich from the MacPorts install. If you enter which kpsewhich in Terminal, it probably points to /opt/local/bin/kpsewhich or something similar.

The easiest way to fix this is to edit your PATH environment variable so that /usr/texbin comes first. If you're using bash, your ~/.bash_profile, you would have something like


Alternately, if macports sets your PATH by sourcing a script in ~/.bash_profile, as Fink does (or did), you can add a final line to your profile of


A couple of notes:

  • this will not affect PATH settings for any GUI applications, only programs launched from a shell
  • for a TeX Live not installed via MacTeX, you'd use the appropriate full path, e.g., /usr/local/texlive/2013/bin/x86_64-darwin instead of /usr/texbin

I had this issue, but none of the above solved it. Here is what worked:

Diagnosing the Issue:

  1. I am on OSX 10.9.5 and installed BasicTex 2015 from here http://www.tug.org/mactex/morepackages.html
  2. I wanted fullpage.sty, but \usepackage{fullpage} was not working
  3. I checked my path using echo $PATH, and /Library/TeX/texbin was the only tex related entry, so that wasn't the problem
  4. kpsewhich fullpage.sty returned nothing, so I knew that latex didn't know where this file was
  5. ls /usr/local/texlive/2015basic/texmf-dist/tex/latex/ returned a list of several packages, but fullpage/ was not among them, so I then knew it was not included with BasicTex and I just needed to install it

Installing the Package:

  1. New packages are installed with sudo tlmgr install fullpage, but this returned the following error:

      tlmgr: package repository
          http://mirror.hmc.edu/ctan/systems/texlive/tlnet tlmgr install:
          package fullpage not present in repository. tlmgr: action install
          returned a warning.
  2. I realized something was amiss, so I looked up the package on CTAN https://www.ctan.org/pkg/fullpage?lang=en and found this very important line:

    The package is part of the preprint bun­dle.

    That was the key clue. I just needed to install the "preprint" package.


  1. I installed the "preprint" package via sudo tlmgr install preprint. This was successful:

      tlmgr: package repository
          http://ctan.mirrors.hoobly.com/systems/texlive/tlnet [1/1,
          ??:??/??:??] install: preprint [7k] tlmgr: package log updated:
          /usr/local/texlive/2015basic/texmf-var/web2c/tlmgr.log running
          mktexlsr ... done running mktexlsr.


  1. I checked the install with kpsewhich fullpage.sty, and this time it returned /usr/local/texlive/2015basic/texmf-dist/tex/latex/preprint/fullpage.sty, which confirmed the solution. I then recompiled my document and it worked.

Boom. Hope this helps someone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.