1

That pretty much says it all. I'm on a mac, using Texmaker, gnuplot works well with aquaterm, I can pass code for diagrams from GeoGebra (geometry package) that works fine.

It seems like using gnuplot is the issue.

I get the following in my log file:

runsystem(gnuplot kjhgf.func0.gnuplot)...disabled (restricted).
Package pgf Warning: Plot data file `kjhgf.func0.table' not found. on input 
line 22.

I am wondering how to "unrestrict" gnuplot (I assume runsystem is not the offender) or fully enable \write18.

I've tried -shell-escape (and -enable-write18) and many of its variants, although I have a lot of options in Texmaker's preferences.

9
  • 1
    You have to enable --shell-escape while compiling and have gnuplot installed in your system.
    – user11232
    Feb 17, 2014 at 22:23
  • thanks for the quick reply. i've got gnuplot installed (i can call it from the terminal and create graphics in aquaterm). i may not be enabling --shell-escape properly, but i have tried to in numerous ways.
    – scott
    Feb 17, 2014 at 22:28
  • Can you try running LaTeX from the Terminal with pdflatex -shell-escape, instead of running it from Texmaker?
    – egreg
    Feb 17, 2014 at 22:33
  • omg! sure. i tried it and it seems to do the job ...
    – scott
    Feb 17, 2014 at 22:37
  • ... although i am now staring at ** as a prompt with a couple dozen lines of code to deal with.
    – scott
    Feb 17, 2014 at 22:38

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.