0

Here's my MWE (this is an actual bibliography item, the draft option is there to show the overfull hbox):

\documentclass[draft]{article}

\usepackage{filecontents}
\begin{filecontents*}{x.bib}
@BOOK{LV12,
  title = {Algebraic operads},
  publisher = {Springer},
  year = {2012},
  author = {Loday, Jean-Louis and Vallette, Bruno},
  volume = {346},
  pages = {xxiv+634},
  series = {Grundlehren der Mathematischen Wissenschaften [Fundamental Principles
    of Mathematical Sciences]},
  address = {Heidelberg},
  doi = {10.1007/978-3-642-30362-3},
  isbn = {978-3-642-30361-6},
}
\end{filecontents*}

\usepackage{biblatex}
\addbibresource{x.bib}

\begin{document}
\nocite{*}
\printbibliography
\end{document}

This produces:

Overfull \hbox (15.12822pt too wide) in paragraph at lines 27--27

I'm generally aware of how to fix overfull hbox from text I wrote myself, but not when the text is produced by a package. What is the best course of action here? Altering the entry is not an option.

3

As egre pointed out in the comments, you can add the hyphenation for specific words. Another possibility is to load the corresponding hyphenation patterns (along with the language dependent words), for example by loading package babel with the option ngerman. A problem arises, when you have different entries of different languages, which biblatex cannot handle so far.

So, you still need some manual labour.

\documentclass[draft]{article}
%\usepackage[ngerman]{babel}
\hyphenation{Grund-leh-ren Ma-the-ma-ti-cal}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
    @BOOK{LV12,
        title = {Algebraic operads},
        publisher = {Springer},
        year = {2012},
        author = {Loday, Jean-Louis and Vallette, Bruno},
        volume = {346},
        pages = {xxiv+634},
        series = {Grundlehren der Mathematischen Wissenschaften [Fundamental
        Principles of Mathematical Sciences]},
        address = {Heidelberg},
        doi = {10.1007/978-3-642-30362-3},
        isbn = {978-3-642-30361-6},
    }
\end{filecontents*}

\usepackage{biblatex}
\addbibresource{\jobname.bib}

\begin{document}
\nocite{*}
\printbibliography
\end{document}
2

An automatic solution would be to set \emergencystretch to 2em-3em before the \printbibliography .

Source: What is the meaning of \fussy, \sloppy, \emergencystretch, \tolerance, \hbadness?

This setting is safe to use for the whole document too: Automatic fallback from \fussy to \sloppy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.