4

I'm using biblatex-chicago to format my dissertation, and everything works very well, except for one particular issue. My bibliography items are each double-spaced, rather than single-spaced, which is the format I need. I am using XeLaTeX, if that helps, and the biblatex-chicago authordate format.

Here is a sample of the output I receive now: Imgur

I'd really like to get rid of that extra space between lines and have the spacing look exactly like this example:

Imgur

Is there something I need to add in my preamble to achieve this? I looked through the BibLaTeX and BibLaTeX-chicago manuals and couldn't really find anything helpful, aside from perhaps \bibitemsep.

Thank you very much in advance, and do let me know if you require any more information.

EDIT: Here's the .cls file I'm using, per the requirements of my school: ufthesis.cls -- and also a custom .sty they require us to use, ufenumerate.sty

Here's a MWE:

\documentclass[12pt,dvipdfmx,final,CPage]{ufthesis}
\usepackage[dvipdfmx]{graphicx}
\usepackage{url}
\usepackage[letterpaper,hmargin=1in,vmargin=1in]{geometry}
\usepackage{lscape}
\usepackage{hanging}
\usepackage{setspace}
\usepackage{ufenumerate}
 \usepackage[format=hang,justification=raggedright,singlelinecheck=0,labelsep=period]{caption}
\usepackage{fontspec}
\usepackage[authordate,backend=biber]{biblatex-chicago}
\usepackage[autostyle=true,english=american]{csquotes}
\addbibresource{biblatex-examples.bib}
\usepackage{hypernat}
\usepackage[dvipdfmx,hyperfootnotes=false]{hyperref}
\hypersetup{colorlinks=true,linkcolor=blue,anchorcolor=blue,citecolor=blue,filecolor=blue,urlcolor=blue,bookmarksnumbered=true,pdfview=FitB} 

\renewcommand{\topfraction}{0.85}
\renewcommand{\textfraction}{0.1}
\renewcommand{\floatpagefraction}{0.75}
\begin{document}
As\footcite[See][]{knuth:ct:a,knuth:ct:b} was discovered \textcite[210]{cicero} and \textcite[210]{wilde} \parencite[210]{cicero} and \cite[210]{wilde}.

\textcite{wilde,cicero} vs \parencite{wilde,cicero}.\footcite{wilde}

\textcite{baez/article,wilde,cicero} vs \parencite{baez/article,wilde,cicero}.
\printbibliography[title=REFERENCES]
\end{document}

I did try the {\singlespacing\printbibliography} command, but it did not change anything. Hopefully this extra information should help.

EDIT: even slimming down the MWE per your suggestions, the issue still occurs. I'm required to use many of these options for my .cls, so it's not really feasible to remove any of them. I've tried to cut out the worst of the cruft, because there certainly is some there.

  • Which document class are you using? Which settings do you use to have double-spacing in the text? Can you provide please a minimal, complete document illustrating the problem? – Gonzalo Medina Feb 19 '14 at 2:57
  • I can't get a document to even compile using biblatex-chicago which seems weird. (I used to use it as standard.) – cfr Feb 19 '14 at 3:22
  • You may try: {\singlespacing\printbibliography}. (And \usepackage{setspace} in the preamble.) – n.r. Feb 19 '14 at 5:35
  • Please post a full MWE. It looks like you are using some kind of double-spacing in your document, we will need to know how you got that going in order to switch it off for the bibliography. Not having seen any code, my best guess is something along the lines of nicolai.rostov's suggestion. bibitemsep controls spacing between items, not between lines in the bibliography; but I think you might also have to adjust that length in order to get what you want. – moewe Feb 19 '14 at 8:01
  • 1
    You can probably add: \setboolean{SetDSpace}{false} right before \printbibliography and get single spacing back. The problem is your class relies on idiosyncratic (if not questionable) methods for setting single and double spacing... You might need to do a \setboolean{SetDSpace}{true} depending on what comes after the bibliography. (Probably nothing, but FYI.) – jon Feb 19 '14 at 20:47
1

Per jon's comment above, \setboolean{SetDSpace}{false} worked, with my custom .cls, to change double- to single-spacing, and \setboolean{SetDSpace}{true} will restore double-spacing.

Thank you all for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.