8

I have Texmaker 4.1.1 and autocomplete feature for citations doesn't work in it. I have my .bib file in the correct directory (the same as my .tex file), use biblatex, have added the command \addbibresource{<my .bib file>} in the correct place in the .tex file, and have already tried refreshing bibliography from Edit menu. Could you suggest some way to fix this?

7
  • 2
    Options-->Configure Texmaker-->Editor-->Is completion checked on and add .bib extension \addbibresource{biblatex-examples.bib}. Check if you can see bib file-name in Structure on left side pane. Feb 19, 2014 at 15:35
  • @texenthusiast Why not add an answer? :)
    – user11232
    Feb 20, 2014 at 0:42
  • @HarishKumar Just to be safe, I am waiting reply from OP if my suggestion worked. Feb 20, 2014 at 2:43
  • @texenthusiast Some times (actually most of the times) you won't get reply if it works ;). Hence make it an answer :)
    – user11232
    Feb 20, 2014 at 6:39
  • 1
    I found that closing and oppening the programme works really well. Be sure to try that
    – erncyp
    Sep 23, 2015 at 14:25

6 Answers 6

11

Made comment into answer which satisfied the OP

Options-->Configure Texmaker-->Editor--> Is completion checked on and add .bib extension \addbibresource{biblatex-examples.bib}. Check if you can see .bib file in Structure on left side pane or open the .bib file with Texmaker from File menu.

2
  • 9
    Sometimes I need to also press Edit -> Refresh Bibliography to make the new entries appear. (Alt-E, <Up>, <Enter>)
    – np8
    Aug 21, 2016 at 8:42
  • worth mentioning that this Refresh Bibliography trick needs to be done in Master in order to work, not in another script with e.g. sections.
    – joaoal
    Jan 17, 2020 at 9:40
2

I found it out now after several tests. I have the following file for all bibliography stuff:

\renewcommand{\bibname} {C Literaturverzeichnis} 
\bibliographystyle{alphadin} 
\bibliography{bibtex/entries} 
\addcontentsline{toc}{section}{\bibname}

And I had the same issue like you. Everything is working and the bibliography and literature is correctly referenced. But I do not have any cite popup/sugguestion.

So the only thing I needed to do to always get it working, was opening the file with the commands above and one time hit compile. Now I always get the cite popups again.

I don't know to do that automatically, but at least it's working again now. Maybe someone could share how to do that?

1
  • Well it's a currently working solution. It just contains a question but that question is not needed to fix the issues. And the other solution above did not work when I was trying it right now. So I decided to show my solution here. Where is the problem guys?
    – kwoxer
    Apr 13, 2015 at 12:43
1

In Windows 7 and MikTex(basic-miktex-2.9.5105)+TexMaker4.3+bibtex file, I found that if I use command like these:

\bibliographystyle{bst file name} \bibliography {bib file name}

then \cite will not auto-complete.

yet however if I use command like these:

\bibliographystyle{bst file name} \bibliography{bib file name}

then \cite will auto-complete the reference normally.

The only difference is that there is a space between \bibliography and {bib file name} or not.

It should be noted that both of the above could display the reference in article normally.

1
  • Actually, for me on Windows 10 the opposite worked. Without the space, i.e. \bibliography{bib file name}, the auto-completion was not working. By adding the space and recompiling, the auto-completion worked. After this, I removed the space and compiled again, and the auto-completion was still working
    – cholo14
    Nov 8, 2020 at 13:27
0

Make sure to load the .bib file from your master document (root .tex file), loading it from and \input or \include will cause trouble.

It would look something like:

\documentclass[a4paper,11pt,oneside]{memoir}
    \input{Preamble}
    \bibliography{BIBLIOGRAPHY} % load the .bib here.
\begin{document}
    \cite{what ever} % should now run with auto compile.
\end{document}

Obv, you should remember to load BibLaTeX and set styles in your preamble.

1
  • I don't think that \bibliography in the preamble will give the desired output. Mar 3, 2017 at 12:32
0

What worked for me is

Options-->Configure Texmaker-->Editor

and then check the checkbox near "check for external changes"

0

I had to add .bib to the name of the bibliography file:

so instead of \bibliography{bibliographyfilename} I have \bibliography{bibliographyfilename.bib} and now it works...

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.