Currently, the MiKTeX package manager does not know of the latest stable version of PGF/TikZ. I have made an attempt at installing it manually, following Stephan Kottwitz’ answer to question How can I manually install a package on MiKTeX (Windows) as a guide, but I get stuck at the following steps:

You could extract it to the right place. Also here, as after any installation

After downloading the package from SourceForge, I found that it contains C code in the .\source\generic\pgf\c directory, which does not seem to belong in my ~\AppData\Roaming\MiKTeX\2.9\source directory.

How should I install this into the latest MiKTeX distro (2.9.5105 x86_64)?

PS: If you're wondering why I would need that, it's because someone suggested it to me.

  • Not only MiKTeX does not know of it, but also TeX Live, simply because it is not yet available from CTAN. Your real problem seems to be, that you downloaded the sources, not the TDS version.
    – Speravir
    Feb 21, 2014 at 21:47
  • PGF 3.0 is now on CTAN, so it should probably show up in MikTeX soon, if it hasn't already. It is in TeX Live at least. Feb 27, 2014 at 21:05

2 Answers 2


Download the tds.zip https://sourceforge.net/projects/pgf/files/latest/download?source=files

Unpack the zip file somewhere outside your miktex system. Then add the root folder as a new root in miktex settings. When pgf is available throught the package manager you can simple remove the root in miktex settings again.

  • 3
    Just in case, I try to keep some builds of PGF/TikZ in here: bitbucket.org/cereda/tikzpgf-builds (with the last commit being the most updated built version - I'm building a new one as I write this comment). :) Feb 21, 2014 at 17:25

As of now, (probably actually a few months back.)

PGF 3 is in MikTeX.

Open up the MikTex Package Manager and Click remove on the pgf package, (if you have it already) then click add again to get the new version, or run the update wzard

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .