5

This is my first time using docstrip. I've written the attempt.dtx file shown below. However, if I compile attempt.dtx using

pdflatex attempt.dtx

the generated documentation starts by a blank page (immediately followed by the title page). My TeX distro (TeX Live 2013) is up to date. I've compared my dtx to others on CTAN to identify what I'm doing wrong, but I seem to be doing everything right...

Where is that blank page coming from and how can I get rid of it?

attempt.dtx

% \iffalse meta-comment
%
% Copyright blah blah blah
%
% \fi
%
% \iffalse
%<package>\NeedsTeXFormat{LaTeX2e}[2011/06/27]
%<package>\ProvidesPackage{attempt}
%<package>  [2014/02/21 v0.1 test test test]
%
%<*driver>
\documentclass{ltxdoc}
\usepackage{attempt}
\EnableCrossrefs
\CodelineIndex
\RecordChanges
\begin{document}
  \DocInput{attempt.dtx}
\end{document}
%</driver>
% \fi
%
% \CheckSum{0}
%
% \GetFileInfo{attempt.sty}
%
% \title{attempt}
% \author{Jubobs}
% \date{\filedate}
% \maketitle
%
% \begin{abstract}
%   test test test
% \end{abstract}
%
% \section{Introduction}
%
% \StopEventually{\PrintIndex}
%
% \section{Implementation}
%
% \Finale
\endinput
6

If I paste the line

% \GetFileInfo{attempt.sty}

in the http://rishida.net/tools/conversion/ input box, I get, in the Unicode U+hex box

% U+FFFC\GetFileInfo{attempt.sty}

So it's a spurious character that produces the problem. It appears as three bytes if Unicode is disabled; here's what less shows:

% <EF><BF><BC>\GetFileInfo{attempt.sty}

In the .log file you find

 (./attempt.dtx
Missing character: There is no <EF> in font cmr10!
Missing character: There is no <BF> in font cmr10!
Missing character: There is no <BC> in font cmr10!
 [1

that's also a way to find the culprit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.