5

I have a problem with encoding Polish letters in TeXmaker. What I mean by this is that:

  • when I write Polish letters in TeXmaker they are visible as Polish letters: ą, ę, ć and so on
  • yet after compilation what I get in dvi or pdf are just question marks
  • similarly, if I open tex file written in TeXmaker and containing Polish letters in WinEdt, what I get are question marks as well
  • if I produce a file containing polish letters in TeXmaker, close it and re-open in TeXmaker — again question marks

I know there must be some problem with encoding, yet I have no idea how to solve it.

The question has been marked as duplicate, however the original answer which was pointed to me does not concern the problem of Polish signs in TeXmaker and in a source file. Texenthusiast's answer below helped me to solve that problem as well.

  • 2
    Options-->configure texmaker-->Editor-->Editor font encoding-->utf-8 Press Ok and restart texmaker. Always use unicode. may be see if this is relevant xm1math.net/texmaker/download.html "Installing the ibus-qt package is recommended to avoid some trouble with accentued characters on some linux distributions (for Qt4 versions only)". Finally Now start typing polish and save and run pdflatex to verify pdf file. – texenthusiast Feb 21 '14 at 20:21
  • 3
    BTW one should add \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} to the preamble for compiling the .tex file with unicode characters. – texenthusiast Feb 21 '14 at 20:50
  • @texenthusiast I have followed your instruction, i.e. I set TeXmaker to utf-8. When I include <code>\usepackage[utf8]{inputenc}</code> in the preamble, then I get very strange looking symbols for polish letters. Without it I get the following error for every polish letter: <code>! Package inputenc Error: Unicode char \u8:ś not set up for use with LaTeX.</code> However, when I re-open file, I still can see polish letters in the file. – Mad Hatter Feb 21 '14 at 21:28
  • 1
    @Alan Only partially, since I also experienced problem with encoding in TeXmaker itself. But your link will be very useful for me. Thanks. – Mad Hatter Feb 21 '14 at 22:45
  • 1
    @MadHatter: The TeX file itself must be saved in UTF-8, or if it was already saved in another encoding, it must be converted. – Speravir Feb 22 '14 at 3:08
6

Step 1: Change Editor Encoding utf-8 that supports unicode characters

Close all opened .tex files inside Texmaker and now go to Options-->Configure texmaker-->Editor-->Editor font encoding-->utf-8 Press Ok and restart texmaker to take the encoding into effect.

Relevant info for Linux users about ibus-qt package

http://xm1math.net/texmaker/download.html "Installing the ibus-qt package is recommended to avoid some trouble with accentued characters on some linux distributions (for Qt4 versions only)".

Step 2: Now How to type special/accented letters in LaTeX? by loading inputenc and fontenc in Preamble.

Add

\usepackage[utf8]{inputenc} % `utf8` option to match Editor encoding
\usepackage[T1]{fontenc}

to the preamble before compiling the .tex file with unicode characters to correctly reflect in .pdf file . Finally now start typing polish language with above preamble, save and run pdflatex file-name to get required pdf file

Alternative to Step 2 some people might prefer using xelatex unicode LaTeX engine by loading fontspec with more font options compared to pdflatex.

Note: Use a cross-platform unicode LaTeX editor from the LaTeX Editors/IDEs

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.