1

Somewhat opposite to other problems I found, my document size is correct when compiling with pdflatex but is not right when compiling with latex.

I'm using a custom documentclass for a conference but I don't think that is the problem. The document template provided is defining the paper size precisely with the {geometry} package.

This is my preamble:

\documentclass[runningheads]{llncs}
\usepackage{graphicx}
\usepackage{amsmath,amssymb} % define this before the line numbering.
\usepackage{ruler}
\usepackage{color}
\usepackage[width=122mm,left=12mm,paperwidth=146mm,height=193mm,top=12mm,paperheight=217mm]
{geometry}

When I compile it with pdflatex, I get the correct document (much smaller than A4). However, I would like to compile it with latex (and then do dvi->ps, ps->pdf conversion) in order to be albe to use .eps images.

But, when compiling with latex I get a smaller page embedded in an A4 with big lower and right margins. Could anybody please suggest a solution?

  • geometry also provides paper=letterpaper as an option... – Werner Feb 26 '14 at 15:44
  • @Werner I know, but this is a conference document template, not something I wrote myself, and it's mostly not a good idea to change things in the provided template if not needed. – penelope Feb 26 '14 at 15:46
  • You are setting paperwidth to 146mm in your preamble and so you should get this width with pdflatex (and no letter or a4 or something else). With latex + dvips the result depends on the config.ps. In a current texsystem you can load eps-graphics with pdflatex by using the epstopdf package. – Ulrike Fischer Feb 26 '14 at 16:04
  • @UlrikeFischer Sorry, you're right, it's not letter size, it's just "smaller than A4". I corrected that. I will try the epstopdf package. – penelope Feb 26 '14 at 16:09
2

Too long for a comment.

With the files you have provided I get:

  • pdflatex: 413.858bp = 5.748in = 146mm × 615.118bp = 8.5433in = 217mm
  • latex/dvips/ps2pdf: 413.86bp x 615.12bp

The only difference I see is the rounding of two decimal digits instead of three that pdflatex has used.

As expected the pages are neither in A4 or letter size, because you have specified:

\usepackage[width=122mm,left=12mm,paperwidth=146mm,height=193mm,top=12mm,paperheight=217mm] {geometry}

The result, checked with pdfinfo is indeed 146mm × 217mm. Thus package geometry has done its job.

BTW, is eccv2014kit an ancient file, its producer entry:

Producer:       GNU Ghostscript 6.51

I found a release date for 6.60: 2000-12-31
The current version is 9.10!

Is the TeX distribution has the same age, then update, then it should work, if the correct option settings are given to geometry, and the question can be closed as "off topic because of old software".

  • Well, I use a newer version of TeX, not from 2000. And, I just checked my papersizes: for pdflatex it's 5.75x8.54 inch, for latex it's 8.5x11 inch. – penelope Feb 26 '14 at 16:35
  • @penelope: Checked out a newer version of ghostscript? Versions of geometry, dvips are uptodate? – Heiko Oberdiek Feb 26 '14 at 16:58
  • @penelope in older version of geometry you had to set the driver (dvips) to get correct values. And - as I wrote - the config.ps can affect page sizes: dvips has to set them in a way that ps2pdf can't ignore them. – Ulrike Fischer Feb 26 '14 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.