1

When I use \footcites for multiple citations, I get a semicolon delimited list of citations, but I don't get any space.an example of a poorly formatted citation

In what may be a related problem, if I use the prenote field in \footcite, I similarly do not get a space between the prenote and the citation. (I've worked around this by using a citation command within \footnote.)

These are my biblatex macros:

\RequirePackage[style=historian,autopunct=true,abbreviate=false,citestyle=verbose-ibid,bibstyle=historian,backend=biber,isbn=false,language=american,sorting=nyt,pagetracker=false,printseries=true]{biblatex}
\DefineBibliographyStrings{american}{%
    namedash={---------},%
    volumeof={of},
    editor={Edited by},
    translator={Translated by},
    ibidem={Ibid.},
    phdthesis={Ph.D. diss.,}
}
\DeclareNameAlias{labelname}{first-last}
  • 1
    Please make your code compilable (if possible), or at least complete it with \documentclass{...}, the required \usepackage's, \begin{document}, and \end{document}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem. – jub0bs Feb 26 '14 at 20:09
  • Don't define bibliographical strings in ways which are less flexible than the original versions. I'm not sure this is the source of the problem in this case but it is definitely a potential source of other problems. editor and translator should not be defined that way, for example, and should not be capitalised, in any case. Take a look at the default definitions to see how things are set up there. Although you can't use exactly the same syntax with \Define..., it should give you an idea. Why redefine editor, translator etc.? There are also reported issues with historian, though. – cfr Feb 27 '14 at 4:34
  • 1
    hostorian has not been updated for almost three and a half years (last update was in August 2010), biblatex has changed quite a bit since then. The problem seems to lie with historian throwing about a lot of \unspaces that cancel out the \space in \multicitedlim. Your best bet is probably to find a more recent style and use that. (You load style=historian, but then overwrite that by setting citestyle=verbose-ibid,bibstyle=historian. Is that really what you want?) – moewe Feb 27 '14 at 10:35
  • Ahh, I see, if one uses historian as the citestyle we run into unknown commands (as I said: hostorian is quite old). Maybe your best bet is to try verbose-ibid, or biblatex-chicago (try the former first; it's easier to customise). If you need modifications done to those styles to meet your requirements, just ask another question. – moewe Feb 27 '14 at 10:38
  • Okay, thanks. I will have a look at verbose-ibid. – adam.baker Mar 7 '14 at 15:44
1

The resolution to this issue, based on comments to the original question, was to stop using historian, which is no longer developed, and to switch to a customized verbose-ibid.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.