47

First, some general details about my document: I'm using the scrbook class and the hyperref package. The document is split up into different source files (though this fact should not matter in this case).

I constantly get a warning for all of my footnotes (180 in total):

Document.tex:0. name{Hfootnote.xx} has been referenced but does not exist, replaced by a fixed one.

where the xx is replaced by the number of the footnote in the compiled document and is running from 1 to 180 (in my case with 180 footnotes).

The numbering of the footnotes is correct and they appear in the compiled PDF as they should.

The only problem is, that the reference in the document is wrong. Clicking on the index of a footnote (in the text) always brings one to the very first page of the document.

What have I already tried/checked?

  • none of the footnotes is in a table or caption

  • numerous recompiling does not solve any of the warnings

  • some footnotes do contain \url{} but by far not all

Does anybody have got some hints what else I should check?

5
  • 1
    Welcome to TeX.SX. I took the liberty to shorten the title a little bit, so that it fits better in the site layout. Apr 20, 2011 at 16:41
  • 3
    It would be very good if you add a minimal working example (MWE) that illustrates your problem, i.e. create a minimized version of your document which still shows the warnings. You can do this by making a copy and remove all unrelated text and packages. You might even find the cause during this, because often it is some incompatibility with some other package. Apr 20, 2011 at 16:43
  • 1
    Thank you @Martin. Ulrike's hint was somehow easier and faster ;) Nevertheless, the MWE-method you mentioned is worth a try for other problems.
    – Torbjörn
    Apr 20, 2011 at 16:57
  • 1
    K.: Sure if you already found the error there is no need for that effort any longer. See the MWE link above for more tips. Apr 20, 2011 at 16:59
  • 3
    Although the problem was solved, I want to add something: "numerous recompiling does not solve any of the warnings": Sometimes it can also be helpful to delete the auxiliary files and then recompile.
    – Stephen
    Aug 12, 2011 at 14:42

3 Answers 3

53

Well the following works fine. So you should try to find out what your document is doing differently.

\documentclass{scrbook}

\usepackage{hyperref}

\begin{document}
abc\newpage abc\footnote{blub}
\end{document}

My guess is that you are not following the rule "load hyperref as the last package" and that something is redefining footnote.

5
  • 1
    Wow! Thank you a lot @Ulrike! That was the problem. I was loading hyperref prior to packages as fancyhdr, epstopdf and graphicx.
    – Torbjörn
    Apr 20, 2011 at 16:55
  • 3
    "My guess is that you are not following the rule "load hyperref as the last package" and that something is redefining footnote" this was the clue that I found the problem in my code as well, I googled and came to this question and answer, thanks very much for you guys. I think an expert knowledge based on EXPERIENCE is always helpful.
    – user11443
    Feb 4, 2012 at 4:19
  • 1
    @Mammatt: thank your for your comment. It was posted as answer, so I converted it to a comment to Ulrike's answer. A Q&A site is different to forums, which work with threads.
    – Stefan Kottwitz
    Feb 4, 2012 at 8:49
  • @UlrikeFischer: Load it before cleveref?
    – user877329
    Jul 25, 2015 at 14:32
  • In my case my problem was that I actually DID load hyperref as last package, when another package should have been loaded even later. The offending package was doi. This page shows a (long) list of packages that must be loaded after hyperref. -- once again the TeX/LaTeX architecture shows how outdated and hilariously fragile it is :(
    – DerManu
    Mar 28, 2019 at 14:18
11

I ran into a similar problem. Same warning, and same result (footnote links point always point to first page). Turns out, there’s some weird interaction between setspace and hyperref. The solution is to make sure setspace is loaded before hyperref:

\documentclass{book}
\usepackage{setspace}
\usepackage{hyperref}
\begin{document}
Hi.\footnote{Yolo}
\end{document}

Otherwise, if you swap the order, it will cause that same warning.

Note: bookmark also uses hyperref under the hood so a similar problem can arise even if you don’t use hyperref explicitly.

1
  • In my case, this was complicated by the fact that the documentclass loaded hyperref. Here is a workaround I found that doesn't require modifying the class: tex.stackexchange.com/a/462612/123144
    – Zach Boyd
    Dec 10, 2018 at 18:33
6

I had this issue as well, so I went with the \footnotemark[n] where I placed the footnote, then later on in the document: \footnotetext[n]{text}.

I think it was because of the command I placed the footnote in, that it was not working as expected. Outside of the tabular and textit brackets, \footnote worked fine.

1
  • 2
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Aug 15, 2013 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.