I have the feeling this must have been asked before, but I couldn't find it with search...

When I run the following test file



% \pdfmapfile{+rotis.map}

% \renewcommand\rmdefault{rotissemisans}
% \renewcommand\seriesdefault{l}




foo bar




through pdflatex with this PDF file http://www.quinscape.de/download/examples/12462.pdf then I receive the following, expected result:

correct result

But when I uncomment the three lines configuring Rotis Semi Sans Light as the document font, I unexpectedly get:

enter image description here

That is, a lot of characters are missing from the embedded PDF file. I can deduce this has something to do with the fact that the font embedded in the embedded PDF is the same as the document font, combined with font subsetting, but what exactly has gone wrong, and what are my options?

Please excuse that I can't upload the complete font setup. The generated PDF is here: http://www.quinscape.de/download/examples/test.pdf (more precisely, an older version without the nice frame, but with the same error).

Here's the relevant line from the map file:

pr3l8r  RotisSemiSans-Light " TeXBase1Encoding ReEncodeFont " <8r.enc <pr3l8a.pfb

Maybe some expert can analyse something or has seen this before?

Update: When I add the line

\pdfinclusioncopyfonts 1

to the preamble, then I get

enter image description here

which looks Ok, though it does not really relate to what the documentation says this switch does :-)

Here's the relevant part from the pdftex manual, but I can't comprehend the connection to the case at hand:

\pdfinclusioncopyfonts (integer)

If positive, this parameter forces pdfTeX to include fonts from a pdf file loaded with \pdfximage, even if those fonts are available on disk. Bigger files might be created, but included pdf files are sure to be embedded with the adequate fonts; indeed, the fonts on disk might be different from the embedded ones, and glyphs might be missing.

My remaining problem now is that I am generating documents which can contain literally thousands of these embedded diagrams, and I fear that if all the embedded fonts are copied to the document PDF, it might get huge or otherwise too unwieldy for prepress tools...

  • What happens if you don't uncomment the line changing the series default but only the other lines? – cfr Feb 27 '14 at 22:14
  • 1
    This issue has been discussed on the pdftex list here and here, where you find some explanations and another workaround (removing/changing the PostScript name). Yet another solution would be something like {\font\x=pr3l8r \pdfincludechars\x{1234567890.=hmFM}}, which of course requires that you know which characters are used in the diagrams. – Robert Mar 2 '14 at 18:24
  • 2
    ... But I must say that the image file looks fishy to me: The /CharSet entry (which lists the character names of the subset) of the Rotis font only contains the letters /A/a, which are not even used in the diagram. If I change these to /h/m in the included pdf, these two letters do appear in the final pdf (without any workarounds). So you might want to check whether there is anything wrong with the "C&G-PDF-Creator V0.1". – Robert Mar 2 '14 at 18:52
  • 1
    @Robert Your hint is exactly the answer to the question. Would you write an answer on the site please? – Stephan Lehmke Feb 2 '15 at 16:38
  • 1
    sure, could you re-upload the test files? – Robert Feb 3 '15 at 1:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.