2

I would like to run XeLaTeX with Xindy. Therefore I copied the example in question How to use xindy with XeTeX/LuaTeX?. I used the code from where this is written (Herbert’s answer), but I used XeLaTeX instead:

xelatex <file>
xindy -C utf8 -I latex -M myModuleE <file>.idx
xelatex <file>

Using these command codes I get:

Unsupported input markup latex.

When I remove -I latex I get the following error message. Unfortunately I do not get Xindy running anD I get an error message:

*** - PROGN: variable MYMODULEE.XDY has no value

The module "MYMODULEE.XDY" is created and is in the directory of the TeX project. When I tried different other approaches (including different codes) always this error message appears, even though the relevant *.xdy is present and not empty.

Has anyone an idea what goes wrong?

I use a Windows 7 computer with the newest version of TeXworks, and a MacBook with Mac OS X 10.9.1 and TeXworks for mac.

I never before used Xindy, so think it is still a configuration problem. So far I used LaTeX and MakeIndex, but u have many international characters, that is the reason why I would like to switch.

6
  • 3
    BTW: why does your title mention xelatex when your example is using lualatex?
    – daleif
    Commented Feb 27, 2014 at 16:26
  • Do you use TeX Live in also in Windows? MacOS X is a Unix derivate, and therefore the lettercase does matter. So, there is a difference between MyModuleE and MYMODULEE. On the other hand I wonder why here a variable should be involved.
    – Speravir
    Commented Feb 27, 2014 at 23:26
  • Not to forget tis one: Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format.
    – Speravir
    Commented Feb 27, 2014 at 23:26
  • Yes you are right. I did copy the code from the example on this page. but i used xelatex instead of lulatex.
    – Chris
    Commented Feb 28, 2014 at 14:28
  • @Chris: You can always edit your own questions (and answers), also with your low reputation. This time I changed it for you.
    – Speravir
    Commented Feb 28, 2014 at 21:33

1 Answer 1

2
\documentclass{scrartcl}
\usepackage{makeidx}\makeindex
\def\Index#1{#1\index{#1}}
\begin{document}
\Index{foo} \Index{bar}
\newpage \Index{baz}
\printindex
\end{document}

run

xelatex <file>
texindy <file>.idx
xelatex <file>

will produce:

enter image description here

The example which you mentioned, can be run with

texindy -C utf8 -I omega -M myModuleE <file>.idx

and an additional \let\lettergroup\textbf in the preamble of your document

2
  • What is now different to the other (older) answer? Could you, please, add here some remarks or update your old answer? Is it really an issue LuaLaTeX vs. XeLaTeX? I also wonder why now omega should be used and not latex. In a test the difference whether error or not was only xindy vs. texindy (or xindy + module texindy) – after letting \lettergroup to \textbf.
    – Speravir
    Commented Mar 1, 2014 at 0:20
  • Using xelatex, imakeidx (instead of makeidx) and xindy, I had similar problems, cf. this Question. I get an error message when I try to run texindy from imakeidx together with the -C utf8 option. But I need to call -M texindy.xdy, or include (require "texindy.xdy") in my xindy style file. I don't use the -I option at all.
    – Blackface
    Commented Apr 2, 2014 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .