5

I am using sidewaysfigure from the rotating package.
The orientation of the figure is as desired for the double-page layout.
In the pdf (generated through Latex->PS->PDF), the page is rotated so that when viewing the file, the reader can see the figure in its correct orientation.

However, when I want to print the document the page is not rotated when using duplex printing. Instead, I get a shrunken page which is rotated by 90 degrees.

EDIT
Here is a minimal working example that illustrates my problem:

\documentclass[11pt,a4paper,twoside]{book}
\usepackage{rotating}
\usepackage{tikz} % this is just included to generate a "figure"

\begin{document}

This is just a test to show a rotated second page which won't print right in duplex mode.

\begin{sidewaysfigure}
\begin{center}
\begin{tikzpicture}
    \draw[thick,dashed,rounded corners] (12.25,1.5) rectangle (15.58,4.0);
\end{tikzpicture}
\caption{This is my sideways figure}
\end{center}
\end{sidewaysfigure}

\end{document}

The second page will be rotated counterclockwise (as expected), but will also be printed in this orientation:

rotated second page

EDIT 2: Question

How do I suppress the rotation of the page (not of the figure though) in the pdf-document that is created by Latex?
That way, I would not have to worry about any printer settings.

  • 1
    Could you post a minimal working example (MWE) that exhibits the issue? This would give us something to start working with. – Paul Gessler Feb 28 '14 at 4:35
  • Thanks! I just compiled your MWE and printed it twice (once to paper and once to a PDF); it worked as expected in both cases (page number in normal position; figure rotated so the caption is on the outside (left) edge). So it must be some local setting/issue. Unless anyone else has ideas? – Paul Gessler Feb 28 '14 at 16:39
  • 4
    This question appears to be off-topic because it is about a printer-related issue. – Torbjørn T. Apr 24 '14 at 17:43
  • I do not think, it is off-topic, because a page can be rotated in different ways: the physical page format is rotated or the physical page is kept, but the rotation is indicated in the PDF object by the /Rotate key. How both ways can be done in LaTeX is on-topic. – Heiko Oberdiek Apr 24 '14 at 18:06
  • @TorbjørnT. I rephrased the question to make it more Latex specific. – Schorsch Apr 24 '14 at 19:57
2

I've encountered a problem like this before, and for me it was something that happened in the pdf conversion: my own .ps files looked fine. It was solved by running ps2pdf as follows:

ps2pdf -dAutoRotatePages=/None filename.ps

(where filename.ps is replaced with your postscript file)

I tried this with your MWE, and I went from the pdf displaying the rotated page, to all pages oriented in portrait mode.

  • Upvote as this works. I am still curious if there is a fix from within the sidewaysfigure – Schorsch Nov 10 '14 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.