2

The problem is the following:

I'm using classicthesis to write my thesis, and I need the names of the captions displayed in spanish (e.g. "figura" instead of "figure"), so I uncommented the next line, in the classicthesis-config.tex:

\PassOptionsToPackage{spanish,es-lcroman}{babel}
 \usepackage{babel}

So when I make the pdf from one chapter, the captions are displayed in spanish, but when I make the pdf from Classicthesis.lyx (the master document) the output pdf have the captions in english.

I tried changing the idiom of the master document and the child documents, but wasn't help. I don't know what other thing do, I hope you can help me.

3
  • Can you post a complete example?
    – scottkosty
    Feb 28, 2014 at 13:30
  • Actually, the classicthesis-config.tex file should be considered an example of how to load packages and is not an essential part of classicthesis. It is a very badly written file, in my opinion. You can answer your own question, rather than editing it.
    – egreg
    Feb 28, 2014 at 16:16
  • Thanks @egreg I don't have idea, let me changed.
    – Sego
    Feb 28, 2014 at 16:21

1 Answer 1

2

I figured out my own answer, I learned that Lyx only takes into account the preamble of the master document, so I changed language (spanish instead english) of this one in Document>Configuration>Language, but nothing happened.

I looked out the Tex code and I realized that Lyx first load the classicthesis-config.tex and after the Language option, this way:

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% Textclass specific LaTeX commands.
% Classic Thesis Style loader
\makeatother
\input{classicthesis-config.tex}
\makeatletter
% use Latin Modern instead of Computer Modern sans serif
\renewcommand{\sfdefault}{lmss}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
\uspackage{babel}

\addto\shorthandsspanish{\spanishdeactivate{~<>}}

\begin{document}

Then I commented the next line, in the classicthesis-config.tex:

%\PassOptionsToPackage{spanish,es-lcroman}{babel}
 %\usepackage{babel}

And I wrote \usepackage[spanish, es-lcroman]{babel} in the master document's preamble.

I hope this will be useful.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .