3

When I am Running latex interactively, as I like, emacs is opening a new buffer-window with output from the LaTeX compiling process. Fine! -- I like to see the processing outut. BUT I am used to that this buffer (window) always view the last line of the process output. Is there a .emacs "trick" for this to happen?

Best Regards

6
  • 2
    Welcome to TeX.SX! I'm having trouble understanding what you want to do, here. Can you rephrase, or perhaps an example of what you'd like to see? Commented Mar 1, 2014 at 2:17
  • 1
    Is this what is happening: run latex with C-c C-c, and AUCTeX split the (active) buffer and open *<filename> output* in a buffer? This does not happen by default in my setup. And if I open that *output* buffer with C-c C-l, it does automatically open at the end of that 'file'. Do you have some non-default settings in your .emacs?
    – jon
    Commented Mar 1, 2014 at 5:47
  • @jon I suppose he set TeX-show-compilation to t.
    – giordano
    Commented Mar 1, 2014 at 16:14
  • Wrong guess: TeX-interactive-mode shows the compilation buffer without touching TeX-show-compilation.
    – giordano
    Commented Mar 1, 2014 at 16:28
  • @giordano -- Well that makes sense. My non-solution would be to not turn on that setting: but I run latex far to often to want that buffer to show automatically. (I probably need more discipline with the 'focus on the writing' mentality...)
    – jon
    Commented Mar 1, 2014 at 16:50

1 Answer 1

4

I'm answering to remove this question from the unanswered queue.

You should set TeX-show-compilation to t. You can do that by adding the following code to your .emacs:

(setq TeX-show-compilation t)
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .