3

In the idxlayout manual I read that the memoir class with twocolumn options forces a page break after the index. Is there any way around this behavior? I would like the following to remain on one page, not three.

\documentclass[oneside,twocolumn]{memoir}

\usepackage[columns=1]{idxlayout}
\makeindex
\title{Title}

\begin{document}
    \maketitle
    \printindex
    \index{Hi}{Hello}
\end{document}
  • 1
    When you use twocolumn, the only way to switch to one column is ejecting a page. – egreg Mar 4 '14 at 16:25
  • This is for the break before the index? When changing to columns=2, is still get three pages. I am looking for a small list of to do items just after the title, just before the start of the main text. – Marijnn Mar 4 '14 at 16:47
  • 1
    Have you seen the todo package? – egreg Mar 4 '14 at 16:49
  • Thanks, a dedicated package is probably a better way. I think fixme looks nice for my purposes.. – Marijnn Mar 4 '14 at 17:20
  • fixme is very good for this and very powerful when you need it. – cfr Mar 5 '14 at 0:10
2

When you use the twocolumn option, the only possible way for switching to a one column format is starting a new page.

You might use the multicol package, instead, but probably the best strategy for the problem you're trying to solve is using the todo or fixme packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.