1

Trying to run \makeglossaries after I've already compiled the file with pdflatex gives me the error:

**Call to xindy failed*** Check 'settings.glg' for details

In the file 'settings.glg' this is written:

*** Unable to execute: '"xindy" -L english -I xindy -M "settings" -t "settings.glg" -o "settings.gls" "settings.glo"' ***

Status report:

This is my code:

\documentclass{article}

\usepackage[xindy]{glossaries}
\makeglossaries

\newglossaryentry{gloss}{
name=glossaries,
description=A package for generating glossaries in many styles
}

\begin{document}
\texttt{\gls{gloss}} is a great package!
\printglossaries
\end{document}

Everything works when I use \makeindex (\usepackage{glossaries}), but with the warning. About this warning I've already asked the question Makeindex warning.

Could you explain me what I'm doing wrong with xindy?

P.S.

I've installed xindy using this How to use Xindy with MiKTeX? and made settings for my TeXstudio using this post.

4
  • Do you have MiKTeX installed as TeX distribution? I actually suspect so, see How to use Xindy with MiKTeX?.
    – Speravir
    Mar 6 '14 at 1:25
  • Oh, I see your other post Makeindex warning. So, you are using MiKTeX.
    – Speravir
    Mar 6 '14 at 1:30
  • @Speravir I've used this How to use Xindy with MiKTeX?, it did not help, I've mentioned it in my question, but not clearly.
    – saldenisov
    Mar 6 '14 at 18:23
  • Your minimal example works fine here (well, it’s actually mine). Note that the command on terminal is makeglossaries without a backslash! In other words: You did something wrong, but I cannot say from here, what (I suspect it’s a problem of system path inclusion).
    – Speravir
    Mar 6 '14 at 22:35