I have migrated from OS X/TeXShop to Linux/TeXMaker. Something in the configuration must be different, because my project doesn't build the bibliography any longer.

I tried the sequence pdflatex > bibtex (biber) > pdflatex.

My original setting was like this:

% NOTE: do not use backend=biber, this fucks up everything. ignore the uf8 warning,
% we do _not_ use utf8 characters in the .bib files, I don't know where that comes from.

This worked on the Mac. On Linux, biblatex falls back to biber (I'm not sure it did on OS X), and biber finds the correct aux files, nevertheless the second pdflatex run doesn't pick up the output of biber, and I end up with an empty bibliography.

If I do add backend=biber to the above statement, then there are messed up aux files (and this is probably why I put the comment originally):

INFO - This is Biber 1.8 INFO - Logfile is 'main.aux.blg'

ERROR - Cannot find control file 'main.aux.bcf'! - did you pass the "backend=biber" option to BibLaTeX? INFO - ERRORS: 1

So what is wrong here?

  • 4
    You shouldn't call biber main.aux, but biber main (or biber main.bcf). – egreg Mar 6 '14 at 10:03

Thanks @egreg. So indeed, this is what happened:

On OS X I had problems with biber, and also when explicitly specifying bibtex8 as backend, that's why the backend statement was missing.

On Linux, bibtex didn't work out correctly. So I added backend=biber, and then you need to re-assign the "bibtex" command in TeXMaker. In Options -> Configure Texmaker, the default is

bibtex %.aux

And I naively changed this to

biber %.aux

But the correct way to do it is

biber %

After that, running pdflatex > "bibtex" (biber) > pdflatex works fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.