3

Hi I'm using the hepthesis template and I creates a empty page before any new chapter. Since it is build upon scrbook, is there anyway to use something like openany

\documentclass[openany]{hepthesis}

doesn't work...

  • 1
    How about the twoside option? – pluton Mar 7 '14 at 14:53
  • @pluton Thank you for your suggestion. oneside works. You can upgrade your comment to an answer if you wan't. – magu_ Mar 7 '14 at 15:43
  • 1
    Apart from the oneside option this should work with twoside: \PassOptionsToClass{openany}{scrbook}\documentclass[<your_other_options>]{hepthesis}. – Speravir Mar 8 '14 at 0:36
  • @Speravir. Cool this would be something like invoking a baseclass options if I understand it correctly – magu_ Mar 10 '14 at 7:12
3

Apart from setting in oneside mode with

\documentclass[oneside]{hepthesis}

the following works, if you want to stay in twoside mode:

\PassOptionsToClass{openany}{scrbook}
\documentclass{hepthesis}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[english]{babel}
\usepackage{kantlipsum}% just for dummy text

\begin{document}
\chapter{Kantian Introduction}
\kant[1-3]
\chapter{Kantian Criticism}
\kant[4-5]
\end{document}

In this manner many options of hepthesis are passed in background to scrbook, but an option openany is not provided, hence the issue you observed.

|improve this answer|||||
  • It is recommended to specify the particular variant of english rather than leaving it to chance. (english aliases to different variants depending on the version of babel.) – cfr Apr 10 '14 at 1:04
  • @cfr: Where is this recommended? And perhaps hree in TeX.sx we should intentionally choose english? I would otherwise prefer to choose "German English". ;-) – Speravir Apr 10 '14 at 1:18
  • It is because in earlier versions of babel english would refer to either american or british depending on the local language.dat and maybe the version of babel. So writing english would give different output for different people. Since the whole point is that you want your code to produce the same output wherever it is compiled, this is obviously bad. So writing english is a bad example to set. (I can't remember where I read this originally but the details of why are in various editions of language.dat.) Is there not a German kantlipsum? Then you could just use german... – cfr Apr 10 '14 at 1:52
  • I've also added an answer at tex.stackexchange.com/a/170657/39222 because all of the existing answers seem to ignore the problem ;). – cfr Apr 10 '14 at 2:24
  • @cfr: The part with German was fun … my English flavour is German … kantlipsum is English only, but blindtext is programmed by a German and has, of course, a German version. (“Blindtext“ is actually the German word for dummy text.) – Speravir Apr 10 '14 at 3:14
3

The oneside option should work here.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.