3

I have a problem with my (freshly updated) MiKTeX installation: I like to use \mathbbold{1} from the bbold package to obtain a blackboard bold 1. This works with TeX Live under Linux, but for font size 11 it does not work with MiKTeX. If I compile

\documentclass[11pt]{article}
\DeclareSymbolFont{bbold}{U}{bbold}{m}{n}
\DeclareSymbolFontAlphabet{\mathbbold}{bbold}
\newcommand{\ind}{\mathbbold{1}}
\begin{document}
$a$ \tracingall $\mathbbold{1}$
\end{document}

then in the log file I get the line

Missing character: There is no 1 in font bbold11!

and no blackboard bold 1 in the output. With TeX Live (and with font size 10) everything works as expected.

The problem seems to be that under TeX Live, bbold/Ubbold.fd is loaded, whereas under MiKTeX, jknappen\ubbold.fd is loaded. The former uses bbold10.tfm, the latter bbold11.tfm.

How can I solve this problem?

  • I have the latest updates in MiKTeX, but everything works fine... – karlkoeller Mar 7 '14 at 20:29
  • @karlkoeller: Strange ... I just even tried removing the MiKTeX folder in AppData\Local, but the error persists. – Hendrik Vogt Mar 7 '14 at 20:48
  • I get C:/Program Files (x86)/MiKTeX/tex/latex/bbold/ubbold.fd loaded. Also I don't have bbold11.tfm but only C:/Users/Name/AppData/Local/MiKTeX/2.9/fonts/tfm/public/bbold/bbold10.tfm – karlkoeller Mar 7 '14 at 21:10
  • @egreg: Thanks a lot for you help so far. I made a funny test: \IfFileExists{ubbold.fd}{\show\relax}{\show\bye}. Under MiKTeX, this shows \relax, und TeX Live it tries to show \bye although the file ubbold.fd exists!! – Hendrik Vogt Mar 7 '14 at 21:35
  • I confirm that with latest miktex, it works. – user11232 Mar 7 '14 at 23:42
2

I wouldn't count it as a miktex bug if two packages uses the same file name and imho the package maintainer should sort this out and not the tex distribuations.

When such name clashes in the same branch of a texmf tree exists the search result is not predictable -- it can e.g. depend on the installation order, date or whatever.

So you have imho the following possibilities:

  • Move the correct fd-file to tex\latex in a root which is searched first (e.g. your local texmf).
  • Copy the font definitions directly to your document. Then no fd-file will be loaded:

    \documentclass[11pt]{article}
    \DeclareFontEncoding{U}{}{}
    \DeclareFontFamily{U}{bbold}{}
    \DeclareFontShape{U}{bbold}{m}{n}
     {  <5> <6> <7> <8> <9> gen * bbold
       <10> <10.95> bbold10
      <12> <14.4> bbold12
     <17.28> <20.74> <24.88> bbold17
      }{}
    \DeclareSymbolFont{bbold}{U}{bbold}{m}{n}
    \DeclareSymbolFontAlphabet{\mathbbold}{bbold}
    
    \begin{document}
    $\mathbbold{1}$
    \end{document}
    
  • Make a copy of the correct fd-file e.g. as Umybbold.fd and store it somewhere where it can be found and then call declare the font as

    \DeclareSymbolFont{bbold}{U}{mybbold}{m}{n}
    
  • I like option 2 - thanks! But I'm still rather puzzled: Is this really a name clash? One file is Ubbold.fd, the other is ubbold.fd. Ah, maybe I understand now: Under Windows this is a name clash, under Linux it isn't. Correct? – Hendrik Vogt Mar 8 '14 at 20:35
  • 1
    Yes, windows doesn't care about cases in file names. – Ulrike Fischer Mar 8 '14 at 20:37
4

In revision 4975 of TeX Live (2007-09-18) we find the annotation

omit ubbold.fd from jknapltx, clash with Ubbold.fd + sauter bbold disfunctional? (Zdenek Wagner, 9 Aug 2007 16:20:21 +0200)

So my suggestion is to remove the file ubbold.fd from your system and file a bug report to MiKTeX's maintainer.

  • Link: MiKTeX Bugs. – Speravir Mar 8 '14 at 2:08
  • I did remove (or rather, rename) ubbold.fd, but then the system didn't find Ubbold.fd ... at the moment I use the unsatisfactory solution of an additional copy of Ubbold.fd in my working directory. Any ideas? – Hendrik Vogt Mar 8 '14 at 7:04
  • @HendrikVogt Rebuild the font name database. – egreg Mar 8 '14 at 10:34
  • @egreg: Do you mean "Refresh FNDB"? This is did. Otherwise, can you tell me how to rebuild the font name database? – Hendrik Vogt Mar 8 '14 at 11:46
  • @HendrikVogt Sorry, but I can't say more than that. – egreg Mar 8 '14 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.