2

How do I make the space under footnotes disappear? And to space over the footnote's bar?

enter image description here

Code:

\documentclass[12pt,french]{report}
\usepackage{mathptmx}
\usepackage{helvet}
\usepackage{courier}
\usepackage[T1]{fontenc}
\usepackage[cp1250]{inputenc}
\usepackage[a4paper]{geometry}
\geometry{verbose,margin=1in,headheight=12pt,headsep=25pt}
\usepackage{fancyhdr}
\pagestyle{fancy}
\setlength{\parskip}{\medskipamount}
\setlength{\parindent}{0pt}
\usepackage{babel}
\makeatletter
\addto\extrasfrench{%
   \providecommand{\og}{\leavevmode\flqq~}%
   \providecommand{\fg}{\ifdim\lastskip>\z@\unskip\fi~\frqq}%
}
\makeatother
\usepackage{latexsym}
\usepackage{pifont}
\usepackage{color}
\usepackage{float}
\usepackage{textcomp}
\usepackage{graphicx}
\usepackage{setspace}
\usepackage[unicode=true,
 bookmarks=true,bookmarksnumbered=true,bookmarksopen=false,
 breaklinks=true,pdfborder={0 0 0},backref=false,colorlinks=false]
 {hyperref}
\hypersetup{pdftitle={tito},
 pdfauthor={abc},
 pdfkeywords={kiko}}
\usepackage{lipsum} 
\makeatletter
\usepackage{multicol}
\usepackage{fancyhdr}
\usepackage{multirow}
\usepackage{longtable}
\setcounter{secnumdepth}{4}
\setcounter{tocdepth}{4}
\usepackage{array}
\newcommand{\ts}{\textsuperscript}
\renewcommand\theparagraph{\alph{paragraph}.}
\renewcommand\paragraph{\@startsection{paragraph}{4}{\z@}%
                                    {3.25ex \@plus1ex \@minus.2ex}%
                                    {0.5ex \@plus .2ex}%
                                    {\normalfont\normalsize\bfseries}}
\renewcommand*\l@paragraph{\@dottedtocline{4}{10em}{2em}}

\def\thickhrulefill{\leavevmode \leaders
\hrule height 1ex \hfill \kern \z@}

\def\@makechapterhead#1{%
\vspace*{10\p@}%
{\parindent \z@
{\reset@font
\usefont{OT1}{phv}{m}{n}
\LARGE Chapitre \thechapter\par\nobreak}%
\par\nobreak
\vspace*{30\p@}
\interlinepenalty\@M
\usefont{OT1}{ptm}{b}{n}
{\raggedright \Huge #1}%
\par\nobreak
\vskip 20\p@
\hrule height 1pt
\par\nobreak
\vskip 45\p@
}}

\def\@makeschapterhead#1{%
\vspace*{10\p@}%
{\parindent \z@
{\raggedleft \reset@font
\scshape \vphantom{\@chapapp{} \thechapter}
\par\nobreak}%
\par\nobreak
\vspace*{30\p@}
\interlinepenalty\@M
\usefont{OT1}{ptm}{b}{n}
{\raggedright \Huge #1}%
\par\nobreak
\par\nobreak
\vskip 45\p@
}}

\lhead{\nouppercase\leftmark}
\chead{}
\rhead{}
\lfoot{}
\cfoot{\thepage}
\rfoot{}
\renewcommand{\footrulewidth}{0.4pt}

\pretolerance=10000
\hyphenpenalty=10000
\exhyphenpenalty=10000

\AtBeginDocument{
  \def\labelitemi{\Pisymbol{psy}{183}}
  \def\labelitemii{\(\rhd\)}
  \def\labelitemiii{\(\rhd\)}
  \def\labelitemiv{\(\ast\)}
}
\makeatother

\begin{document}
\chapter{Chap}
\lipsum[1]\footnote{\lipsum[1]}
\lipsum[1-8]
\end{document}
4
  • What space under footnotes? Do you mean the vertical spacing between the bottom of the text (whether there is a footnote or not) and the footer?
    – Bernard
    Mar 8, 2014 at 18:54
  • @Bernard, yes that's it!
    – dgs
    Mar 8, 2014 at 19:08
  • You could execute the instruction \usepackage[bottom]{footmisc} in the preamble.
    – Mico
    Mar 8, 2014 at 19:15
  • @Mico, can you please make a show?
    – dgs
    Mar 8, 2014 at 19:21

2 Answers 2

3

To assure that the footnote block is placed at the very bottom of the text block, you could add the following instruction to the preamble:

\usepackage[bottom]{footmisc}

A separate issue is the vertical whitespace between the text block and the page number. Given that you're using the geometry package, simply provide a smaller value for footskip -- the current value is 30pt -- to reduce the amount of whitespace.

2

Here is a (distorted) demonstration of the use of the different vertical parameters. It's \footskip that you have to modify. Adapt it to your needs:

        \documentclass[a4paper, twoside, 11pt]{book}
        \usepackage[utf8]{inputenc}
        \usepackage[T1]{fontenc}
        \usepackage{kantlipsum}
        \pagestyle{plain}

        \skip\footins 2cm
        \setlength{\footnotesep}{1cm}
        \setlength{\footskip}{0pt}

        \begin{document}
        \kant{2}\footnote{This is a first footnote.}\footnote{This is a rather lengthy footnote. Just  above the page number. }
        \kant{3}
        \end{document} 

enter image description here

3
  • Thanks for your response, I'm getting a problem with the vertical space between the footer and footnotes. Here are the spnapshots : 1, 2, 3. I'm using my posted code here. And, I'ven't add the \setlength{\footskip}{0pt} because when I do, one footnote becomes mixed with the footer's line.
    – dgs
    Mar 8, 2014 at 19:51
  • Of course setting footskip to 0 pt is not sensible. I don't fully understand your snapshots (they're not contextual enough), and there's no link to your code, so I can't test it.
    – Bernard
    Mar 8, 2014 at 19:56
  • Thank you very much Bernard. The response of Mico had fixed my issue. i've upvoted your post, and I'm going to upvote some of your past answers.
    – dgs
    Mar 8, 2014 at 20:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .