16

In Norwegian, aa is an (obsolete) alternative spelling of å, but it is still very commonly used in names. In bibliographies, it should as a result be alphabetized as if it said å (cf. Wikipedia). In biblatex, however, it is alphabetized under a. How can I fix this? In the MWE below, the entry Aasen should in fact follow Årst, since Aasen should be treated as Åsen.

\documentclass{article}
\usepackage{polyglossia}
    \setdefaultlanguage{nynorsk}
\usepackage[style = authoryear, language = nynorsk]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{aasen1864,
    AUTHOR = "Ivar Aasen",
    TITLE = "Norsk Grammatik",
    YEAR = "1864"}
@book{aarst2010,
    AUTHOR = "Ole Martin Årst",
    TITLE = "Playing soccer is cool!",
    YEAR = "2010"}
\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

enter image description here

4
  • 4
    Are there any occurrences of aa that are not replacements of å? (You might get into trouble with Aachen/Aabenraa thingy mentioned in Wikipedia.) Your best bet is probably manually using sortname. Copy-pasting the author to sortname and replacing aa with å can be done with Biber's mapping features, but this will sort Aachen under Åchen (probably wrong) and might not work particularly well if you play around with useauthor=false a bit. (I'm not sure whether the upcoming multiscript version 3.0 of biblatex could be of any help here). – moewe Mar 10 '14 at 17:04
  • 4
    @moewe If a Scandinavian name begins in Aa-, it should always be alphabetized as Å-. If there's a foreign name beginning in Aa-, it should not (Aachen and Aabenraa are cities, btw, and wouldn't appear in a bibliography). I guess that would apply to Finnish names like Paavo Aaltonen. So you might be right that using sortname is the way to go here. – Sverre Mar 10 '14 at 17:12
  • 2
    But actually, using sortname = Ivar Åsen doesn't yield the correct result either, because biblatex will treat Å as a kind of A. I will open a new question about this. – Sverre Mar 10 '14 at 17:17
  • 3
    Actually, I found the answer here: heim.ifi.uio.no/dag/latex-links/biblatex-guide.pdf. I need to add sortlocale = nb_NO. – Sverre Mar 10 '14 at 17:23
16

Adding sortlocale = nn_NO (nn for Norwegian nynorsk, nb for Norwegian bokmål) as a package option will ensure that Aa is treated as Å, and that Å is alphabetized last. Cf. the University of Oslo’s Local guide to biblatex.

\documentclass{article}
\usepackage{polyglossia}
    \setdefaultlanguage{nynorsk}
\usepackage[style = authoryear, language = nynorsk, sortlocale = nn_NO]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{aasen1864,
    AUTHOR = "Ivar Aasen",
    TITLE = "Norsk Grammatik",
    YEAR = "1864"}
@book{aarst2010,
    AUTHOR = "Ole Martin Årst",
    TITLE = "Playing soccer is cool!",
    YEAR = "2010"}
@book{lennon1975,
    AUTHOR = "John Lennon",
    TITLE = "I like to play the guitar",
    YEAR = "1975"}
\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

enter image description here


EDIT

With the current version of biber (version 2.10), sortlocale will automatically be set by the command \setdefaultlanguage{nynorsk} from polyglossia, cf. this comment. It is therefore no longer necessary to add an explicit sortlocale = nn_NO as a biblatex option. That is, one can replace the line

\usepackage[style = authoryear, language = nynorsk, sortlocale = nn_NO]

from the MWE above with

\usepackage[style = authoryear, language = nynorsk]{biblatex}

and get the same result.

14
  • That guide will be a very useful resource for anyone trying to get to grips with Biblatex. – Paul Stanley Mar 10 '14 at 17:47
  • Due to bugs (?), this solution does not work with the current versions of biblatex and biber, cf. this question. – Sverre Aug 30 '15 at 17:08
  • On my system (Biber 2.7, MikTeX on Win 10) I get the correct sorting even with \usepackage[style = authoryear]{biblatex} without explicitly setting language = nynorsk, sortlocale = nn_NO. Does that also work for you? – moewe Oct 14 '17 at 9:10
  • @moewe No, I don't. I get the order Årst-Aasen-Lennon instead of Lennon-Årst-Aasen. Biber 2.7. Biblatex version 3.7. Tex live 2017. – Sverre Oct 14 '17 at 10:55
  • 1
    Thank you for updating your answer. In fact the language = nynorsk will also be inferred automatically, so it should not be necessary either. – moewe Jan 10 '18 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.